summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-12 13:10:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-12 13:13:34 +0200
commit04f3e04bb2cf1b8ddc8640d848fc4188616c6904 (patch)
tree5e62eb54fdf14f9a972fd4d54e2fc5266adecbe2 /dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild
parentdev-ros/tf2_py: Bump to 0.6.2. (diff)
downloadgentoo-04f3e04bb2cf1b8ddc8640d848fc4188616c6904.tar.gz
gentoo-04f3e04bb2cf1b8ddc8640d848fc4188616c6904.tar.bz2
gentoo-04f3e04bb2cf1b8ddc8640d848fc4188616c6904.zip
dev-ros/tf2_ros: Bump to 0.6.2.
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild b/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild
new file mode 100644
index 000000000000..0e85b91f5107
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"