summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-05 12:46:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-05 12:58:32 +0100
commit2be3a0eb8eeca9e5a35de14f61a323bd44c80da2 (patch)
tree944d383941af17ac72e408e2914c3553b21b57fb /dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild
parentdev-ros/tf2_ros: Bump to 0.5.13. (diff)
downloadgentoo-2be3a0eb8eeca9e5a35de14f61a323bd44c80da2.tar.gz
gentoo-2be3a0eb8eeca9e5a35de14f61a323bd44c80da2.tar.bz2
gentoo-2be3a0eb8eeca9e5a35de14f61a323bd44c80da2.zip
dev-ros/tf2_sensor_msgs: Bump to 0.5.13.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild')
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild
new file mode 100644
index 000000000000..db9168fc512a
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"