summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-18 17:04:59 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-18 17:18:36 +0100
commitb0350f4f163590778a979a03603e42dc79440a52 (patch)
tree12f5ae48549fe7eeff17b8a5eb32c4ba2486aa9c /dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild
parentdev-ros/tf2_ros: Bump to 0.5.14. (diff)
downloadgentoo-b0350f4f163590778a979a03603e42dc79440a52.tar.gz
gentoo-b0350f4f163590778a979a03603e42dc79440a52.tar.bz2
gentoo-b0350f4f163590778a979a03603e42dc79440a52.zip
dev-ros/tf2_sensor_msgs: Bump to 0.5.14.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild')
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild
new file mode 100644
index 000000000000..e0f5e389eba5
--- /dev/null
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-0.5.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Transform sensor_msgs with tf. Most notably, PointCloud2"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/cmake_modules"