summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 09:49:45 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 09:49:45 +0100
commit4506ef8ea547a9dcad22c9ae85878b8264f31f78 (patch)
tree1be12982704096e3b13f5619dc2748565ef54908 /dev-ros/urg_node
parentdev-ros/laser_proc: Initial import. Ebuild by me. (diff)
downloadgentoo-4506ef8ea547a9dcad22c9ae85878b8264f31f78.tar.gz
gentoo-4506ef8ea547a9dcad22c9ae85878b8264f31f78.tar.bz2
gentoo-4506ef8ea547a9dcad22c9ae85878b8264f31f78.zip
dev-ros/urg_node: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/urg_node')
-rw-r--r--dev-ros/urg_node/Manifest1
-rw-r--r--dev-ros/urg_node/metadata.xml5
-rw-r--r--dev-ros/urg_node/urg_node-0.1.9.ebuild28
-rw-r--r--dev-ros/urg_node/urg_node-9999.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/urg_node/Manifest b/dev-ros/urg_node/Manifest
new file mode 100644
index 000000000000..1ad784195282
--- /dev/null
+++ b/dev-ros/urg_node/Manifest
@@ -0,0 +1 @@
+DIST urg_node-0.1.9.tar.gz 13159 SHA256 b4691da54db803fb7f9d0bd2e2008a58de4a36fa7082dc69a1938c1702994387 SHA512 5b9493363406e80780909c68db50277a8629a6fdad7b012d63431a8e62de35532630e141e7b6664586f18e84915e6d2c6e5183911755a0e0cf13991158a05a97 WHIRLPOOL a0d622d21f7b9234a4c6083bfbcbf7c15a8f5b4e9d5b7a1c7f8217eb944a75e3d7aa997a04bc7d567b183ad7b37275367bc3680a21a79e043a7e1064039fdd32
diff --git a/dev-ros/urg_node/metadata.xml b/dev-ros/urg_node/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/urg_node/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/urg_node/urg_node-0.1.9.ebuild b/dev-ros/urg_node/urg_node-0.1.9.ebuild
new file mode 100644
index 000000000000..e70e01112a0d
--- /dev/null
+++ b/dev-ros/urg_node/urg_node-0.1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urg_c
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/diagnostic_updater
+ dev-ros/laser_proc
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/urg_node/urg_node-9999.ebuild b/dev-ros/urg_node/urg_node-9999.ebuild
new file mode 100644
index 000000000000..e70e01112a0d
--- /dev/null
+++ b/dev-ros/urg_node/urg_node-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urg_c
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/diagnostic_updater
+ dev-ros/laser_proc
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"