summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 13:49:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 13:56:47 +0200
commit4cb3af7d4b856a3c02e658514a77485463f6a74b (patch)
treec08058dbc7270e80f4ce1a76c58c74d6e5688f0a /dev-ros/visp_bridge
parentdev-ros/visp_auto_tracker: Bump to 0.12.1. (diff)
downloadgentoo-4cb3af7d4b856a3c02e658514a77485463f6a74b.tar.gz
gentoo-4cb3af7d4b856a3c02e658514a77485463f6a74b.tar.bz2
gentoo-4cb3af7d4b856a3c02e658514a77485463f6a74b.zip
dev-ros/visp_bridge: Bump to 0.12.1.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/visp_bridge')
-rw-r--r--dev-ros/visp_bridge/Manifest1
-rw-r--r--dev-ros/visp_bridge/visp_bridge-0.12.1.ebuild31
-rw-r--r--dev-ros/visp_bridge/visp_bridge-9999.ebuild6
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-ros/visp_bridge/Manifest b/dev-ros/visp_bridge/Manifest
index f707b6449dde..577d34c98191 100644
--- a/dev-ros/visp_bridge/Manifest
+++ b/dev-ros/visp_bridge/Manifest
@@ -1 +1,2 @@
DIST vision_visp-0.11.1.tar.gz 1014349 BLAKE2B 63148bef65a8361be7cb4a3d27bae4e6440feeeca3ab7183c6c345d4d1a2e0e4f7bc52b265455636ae8e07ddbed0e182c8d0b326b7686cdeda97500203fe3183 SHA512 cb1a09fea7ed2bb74c0c3f5a525d35ef7304dc2c569c6c808cd3751e500b7e32f226436ec4150f63a8280bc3f0c53dfd64757aa09da7344b1ec998130006253c
+DIST vision_visp-0.12.1.tar.gz 1014707 BLAKE2B 0c482268761f75e4e36260bb8a98c32677e500f322b3807eda7e24c35681d5fee628e422b67ab9ae73c6a27b467d600ca5ba72220a09e93b146b97273b5d0d54 SHA512 9e050009a335bd8d7f3c024e460087139b43e5b4c44c2048409176b8503aa81193916e767ce06df48fa5d0f0ca23ac551df7201e92e7de65967b9f2df5a1bf7c
diff --git a/dev-ros/visp_bridge/visp_bridge-0.12.1.ebuild b/dev-ros/visp_bridge/visp_bridge-0.12.1.ebuild
new file mode 100644
index 000000000000..897184ef36a1
--- /dev/null
+++ b/dev-ros/visp_bridge/visp_bridge-0.12.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="noetic-"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts between ROS structures and ViSP structures"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ sci-libs/ViSP:=[xml]
+ dev-ros/roscpp
+ dev-ros/camera_calibration_parsers
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
+fi
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/visp_bridge/visp_bridge-9999.ebuild b/dev-ros/visp_bridge/visp_bridge-9999.ebuild
index ad50242778c0..897184ef36a1 100644
--- a/dev-ros/visp_bridge/visp_bridge-9999.ebuild
+++ b/dev-ros/visp_bridge/visp_bridge-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
ROS_REPO_URI="https://github.com/lagadic/vision_visp"
KEYWORDS="~amd64 ~arm"
-VER_PREFIX="kinetic-"
+VER_PREFIX="noetic-"
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -26,6 +26,6 @@ DEPEND="${RDEPEND}
dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
if [ "${PV#9999}" = "${PV}" ] ; then
- S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+ S="${WORKDIR}/vision_visp-noetic-${PV}/${ROS_SUBDIR}"
fi
PATCHES=( "${FILESDIR}/gcc6.patch" )