summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-23 00:57:36 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-23 01:06:57 +0100
commit83c37249aaef121a99339fa7ca341ca09598a6c8 (patch)
tree570da60d7bd07cb26090ef3dde42a68f3e87dd40 /dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild
parentdev-ros/visp_bridge: Bump to 0.9.1. (diff)
downloadgentoo-83c37249aaef121a99339fa7ca341ca09598a6c8.tar.gz
gentoo-83c37249aaef121a99339fa7ca341ca09598a6c8.tar.bz2
gentoo-83c37249aaef121a99339fa7ca341ca09598a6c8.zip
dev-ros/visp_camera_calibration: Bump to 0.9.1.
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild')
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild
new file mode 100644
index 000000000000..f18c05f6b65a
--- /dev/null
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of cameras using a customizable pattern and ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/camera_calibration_parsers
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/visp_bridge
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi