summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:01:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:41 +0200
commit496a1d791904414348763d35ab4dd44f58acbc49 (patch)
treef6f06653ca7038917388d37e70f8021acb8beb28 /dev-ros/xacro
parentdev-ros/costmap_2d: add := dep on cbridge (diff)
downloadgentoo-496a1d791904414348763d35ab4dd44f58acbc49.tar.gz
gentoo-496a1d791904414348763d35ab4dd44f58acbc49.tar.bz2
gentoo-496a1d791904414348763d35ab4dd44f58acbc49.zip
dev-ros/xacro: convert to python-single
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/xacro')
-rw-r--r--dev-ros/xacro/xacro-1.14.1.ebuild9
-rw-r--r--dev-ros/xacro/xacro-9999.ebuild9
2 files changed, 12 insertions, 6 deletions
diff --git a/dev-ros/xacro/xacro-1.14.1.ebuild b/dev-ros/xacro/xacro-1.14.1.ebuild
index e29730c0f573..70c940ca810a 100644
--- a/dev-ros/xacro/xacro-1.14.1.ebuild
+++ b/dev-ros/xacro/xacro-1.14.1.ebuild
@@ -13,9 +13,12 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+RDEPEND="dev-ros/roslint[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
"
RDEPEND="${RDEPEND}
- dev-ros/roslaunch[${PYTHON_USEDEP}]"
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]"
diff --git a/dev-ros/xacro/xacro-9999.ebuild b/dev-ros/xacro/xacro-9999.ebuild
index e29730c0f573..70c940ca810a 100644
--- a/dev-ros/xacro/xacro-9999.ebuild
+++ b/dev-ros/xacro/xacro-9999.ebuild
@@ -13,9 +13,12 @@ LICENSE="BSD"
SLOT="0"
IUSE=""
-RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+RDEPEND="dev-ros/roslint[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
"
RDEPEND="${RDEPEND}
- dev-ros/roslaunch[${PYTHON_USEDEP}]"
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]"