summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 15:53:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:56 +0200
commit0045ebb34bd79b6e5fd825b6f62d2eb8be24616f (patch)
tree50b17010effaf161be6ddc4d448c0af58e097139 /dev-ros
parentdev-ros/ament_cmake_copyright: initial import (diff)
downloadgentoo-0045ebb34bd79b6e5fd825b6f62d2eb8be24616f.tar.gz
gentoo-0045ebb34bd79b6e5fd825b6f62d2eb8be24616f.tar.bz2
gentoo-0045ebb34bd79b6e5fd825b6f62d2eb8be24616f.zip
dev-ros/ament_xmllint: initial import
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_xmllint/Manifest1
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-0.9.5.ebuild47
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-9999.ebuild47
-rw-r--r--dev-ros/ament_xmllint/metadata.xml11
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-ros/ament_xmllint/Manifest b/dev-ros/ament_xmllint/Manifest
new file mode 100644
index 000000000000..6b51d9c9d13e
--- /dev/null
+++ b/dev-ros/ament_xmllint/Manifest
@@ -0,0 +1 @@
+DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
diff --git a/dev-ros/ament_xmllint/ament_xmllint-0.9.5.ebuild b/dev-ros/ament_xmllint/ament_xmllint-0.9.5.ebuild
new file mode 100644
index 000000000000..d9b72688ca3b
--- /dev/null
+++ b/dev-ros/ament_xmllint/ament_xmllint-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks XML files like the package manifest using xmllint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild b/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild
new file mode 100644
index 000000000000..d9b72688ca3b
--- /dev/null
+++ b/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks XML files like the package manifest using xmllint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-ros/ament_xmllint/metadata.xml b/dev-ros/ament_xmllint/metadata.xml
new file mode 100644
index 000000000000..d5919f1304a0
--- /dev/null
+++ b/dev-ros/ament_xmllint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_lint</remote-id>
+ </upstream>
+</pkgmetadata>