summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-15 17:43:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-15 18:05:42 +0100
commit0402cff651d29ae12291474908ca5f72f6c197be (patch)
tree5af3ebf56969441015f0ec8eb4d6c6b47a3c72ff /dev-ros
parentdev-ros/ament_cmake_uncrustify: bump to 0.12.1 (diff)
downloadgentoo-0402cff651d29ae12291474908ca5f72f6c197be.tar.gz
gentoo-0402cff651d29ae12291474908ca5f72f6c197be.tar.bz2
gentoo-0402cff651d29ae12291474908ca5f72f6c197be.zip
dev-ros/ament_cmake_python: update patch
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild2
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild4
-rw-r--r--dev-ros/ament_cmake_python/files/destdir2.patch26
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
index 1b74358d6449..d4b1a4488aca 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.3.0.ebuild
@@ -39,7 +39,7 @@ BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-PATCHES=( "${FILESDIR}/destdir.patch" )
+PATCHES=( "${FILESDIR}/destdir2.patch" )
python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
index d6ff5f678382..d4b1a4488aca 100644
--- a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,7 +39,7 @@ BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-PATCHES=( "${FILESDIR}/destdir.patch" )
+PATCHES=( "${FILESDIR}/destdir2.patch" )
python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
diff --git a/dev-ros/ament_cmake_python/files/destdir2.patch b/dev-ros/ament_cmake_python/files/destdir2.patch
new file mode 100644
index 000000000000..5278b6e17073
--- /dev/null
+++ b/dev-ros/ament_cmake_python/files/destdir2.patch
@@ -0,0 +1,26 @@
+Index: ament_cmake_python/cmake/ament_python_install_module.cmake
+===================================================================
+--- ament_cmake_python.orig/cmake/ament_python_install_module.cmake
++++ ament_cmake_python/cmake/ament_python_install_module.cmake
+@@ -65,7 +65,7 @@ function(_ament_cmake_python_install_mod
+ "execute_process(
+ COMMAND
+ \"${python_interpreter}\" \"-m\" \"compileall\"
+- \"${CMAKE_INSTALL_PREFIX}/${destination}/${module_file}\"
++ \"\$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${destination}/${module_file}\"
+ )"
+ )
+ endif()
+Index: ament_cmake_python/cmake/ament_python_install_package.cmake
+===================================================================
+--- ament_cmake_python.orig/cmake/ament_python_install_package.cmake
++++ ament_cmake_python/cmake/ament_python_install_package.cmake
+@@ -192,7 +192,7 @@ setup(
+ "execute_process(
+ COMMAND
+ \"${python_interpreter_config}\" \"-m\" \"compileall\"
+- \"${CMAKE_INSTALL_PREFIX}/${ARG_DESTINATION}/${package_name}\"
++ \"\$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${ARG_DESTINATION}/${package_name}\"
+ )"
+ )
+ endif()