summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 08:10:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:13 +0200
commit14c21f44fd3632708684d182b5288b1a67a026b7 (patch)
treeb5d04bd7c116b9ea9bbd6e8417e1f66403bf3ca8 /dev-ros
parentdev-ros/rqt_web: remove old (diff)
downloadgentoo-14c21f44fd3632708684d182b5288b1a67a026b7.tar.gz
gentoo-14c21f44fd3632708684d182b5288b1a67a026b7.tar.bz2
gentoo-14c21f44fd3632708684d182b5288b1a67a026b7.zip
dev-ros/rqt_web: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_web/Manifest1
-rw-r--r--dev-ros/rqt_web/metadata.xml2
-rw-r--r--dev-ros/rqt_web/rqt_web-0.4.8.ebuild24
-rw-r--r--dev-ros/rqt_web/rqt_web-9999.ebuild5
4 files changed, 28 insertions, 4 deletions
diff --git a/dev-ros/rqt_web/Manifest b/dev-ros/rqt_web/Manifest
index 7bb8c4d74093..62ee5cf92a65 100644
--- a/dev-ros/rqt_web/Manifest
+++ b/dev-ros/rqt_web/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_web-0.4.8.tar.gz 5929 SHA256 fe355496bd9eae53b62ba8866d0694c73de69bca7484d2c548f48789148691c2 SHA512 11bba520039d4cf51f0ab9ae35d9cea2ea0a757f52d87bf5b57ec8264ec7b4cf0d912c958dac7a01cc3479e643b0334a26053cf4dea31b6ec1d932ed4d566d26 WHIRLPOOL 40f66b58e11bdc764f9b40e6e2c10798ecde26bc3a5b94f0cfd55a0e8f24ac834ccacea765866badfbeb2267fb060810e32f61ae59e975c99963baaffafe5d62
diff --git a/dev-ros/rqt_web/metadata.xml b/dev-ros/rqt_web/metadata.xml
index cb473d142b8e..6d9d6a8aea8a 100644
--- a/dev-ros/rqt_web/metadata.xml
+++ b/dev-ros/rqt_web/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_web</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_web/rqt_web-0.4.8.ebuild b/dev-ros/rqt_web/rqt_web-0.4.8.ebuild
new file mode 100644
index 000000000000..d36e43c52ba4
--- /dev/null
+++ b/dev-ros/rqt_web/rqt_web-0.4.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_web"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Simple web content viewer for rqt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_web/rqt_web-9999.ebuild b/dev-ros/rqt_web/rqt_web-9999.ebuild
index e16117826244..d36e43c52ba4 100644
--- a/dev-ros/rqt_web/rqt_web-9999.ebuild
+++ b/dev-ros/rqt_web/rqt_web-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_web"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin