summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-28 16:04:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-28 16:04:28 +0100
commit2701f4e2ecddcdce15248edf2f4d66936b3187ef (patch)
tree07d21d0ca257b96f2a375cf2f287831fdb7406d5 /dev-ros
parentdev-ros/rviz_plugin_tutorials: drop install path patch now that rospack retur... (diff)
downloadgentoo-2701f4e2ecddcdce15248edf2f4d66936b3187ef.tar.gz
gentoo-2701f4e2ecddcdce15248edf2f4d66936b3187ef.tar.bz2
gentoo-2701f4e2ecddcdce15248edf2f4d66936b3187ef.zip
dev-ros/pluginlib: look for package.xml in ros_packages too for plugins.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/pluginlib/files/gentoo.patch34
-rw-r--r--dev-ros/pluginlib/pluginlib-1.10.4-r1.ebuild (renamed from dev-ros/pluginlib/pluginlib-1.10.4.ebuild)1
-rw-r--r--dev-ros/pluginlib/pluginlib-9999.ebuild1
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/files/gentoo.patch b/dev-ros/pluginlib/files/gentoo.patch
new file mode 100644
index 000000000000..6737f7666df1
--- /dev/null
+++ b/dev-ros/pluginlib/files/gentoo.patch
@@ -0,0 +1,34 @@
+Find package.xml in ros_packages/package_name too as we moved it here.
+
+Index: pluginlib-1.10.4/include/pluginlib/class_loader_imp.h
+===================================================================
+--- pluginlib-1.10.4.orig/include/pluginlib/class_loader_imp.h
++++ pluginlib-1.10.4/include/pluginlib/class_loader_imp.h
+@@ -444,6 +444,7 @@ namespace pluginlib
+ std::string package_name;
+ boost::filesystem::path p(plugin_xml_file_path);
+ boost::filesystem::path parent = p.parent_path();
++ boost::filesystem::path basename = p.filename();
+
+ //Figure out exactly which package the passed XML file is exported by.
+ while (true)
+@@ -453,6 +454,11 @@ namespace pluginlib
+ std::string package_file_path = (boost::filesystem::path(parent / "package.xml")).string();
+ return(extractPackageNameFromPackageXML(package_file_path));
+ }
++ else if(boost::filesystem::exists(parent / "ros_packages" / basename / "package.xml"))
++ {
++ std::string package_file_path = (boost::filesystem::path(parent / "ros_packages" / basename / "package.xml")).string();
++ return(extractPackageNameFromPackageXML(package_file_path));
++ }
+ else if (boost::filesystem::exists(parent / "manifest.xml"))
+ {
+ #if BOOST_FILESYSTEM_VERSION >= 3
+@@ -470,6 +476,7 @@ namespace pluginlib
+ }
+
+ //Recursive case - hop one folder up
++ basename = parent.filename();
+ parent = parent.parent_path().string();
+
+ //Base case - reached root and cannot find what we're looking for
diff --git a/dev-ros/pluginlib/pluginlib-1.10.4.ebuild b/dev-ros/pluginlib/pluginlib-1.10.4-r1.ebuild
index 2791a4dd8460..a96bdaea328a 100644
--- a/dev-ros/pluginlib/pluginlib-1.10.4.ebuild
+++ b/dev-ros/pluginlib/pluginlib-1.10.4-r1.ebuild
@@ -25,3 +25,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-9999.ebuild b/dev-ros/pluginlib/pluginlib-9999.ebuild
index 2791a4dd8460..a96bdaea328a 100644
--- a/dev-ros/pluginlib/pluginlib-9999.ebuild
+++ b/dev-ros/pluginlib/pluginlib-9999.ebuild
@@ -25,3 +25,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gentoo.patch" )