summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-07-20 13:22:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-07-20 13:23:16 +0200
commit2c146a81251ac045d27a792fc1cf80a42a3c2b9d (patch)
tree10d4ba6e14c912a4091d3cfd433a85dc3fe48610 /dev-ros
parentdev-ros/message_filters: Remove old (diff)
downloadgentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.tar.gz
gentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.tar.bz2
gentoo-2c146a81251ac045d27a792fc1cf80a42a3c2b9d.zip
dev-ros/message_filters: upstream boost fix
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/message_filters/files/boost.patch26
-rw-r--r--dev-ros/message_filters/message_filters-1.14.3-r1.ebuild (renamed from dev-ros/message_filters/message_filters-1.14.3.ebuild)2
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-ros/message_filters/files/boost.patch b/dev-ros/message_filters/files/boost.patch
new file mode 100644
index 000000000000..1acc778756a8
--- /dev/null
+++ b/dev-ros/message_filters/files/boost.patch
@@ -0,0 +1,26 @@
+commit 41f18edc9f2f0b1ef304ea25f148bd56a6bf3d70
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 31 00:58:29 2019 +0100
+
+ Remove signals from find_package(Boost COMPONENTS ...) (#1580)
+
+ The packages use signals2, not signals. Only boost libraries with
+ compiled code should be passed to find_package(Boost COMPONENTS ...),
+ and the signals2 library has always been header only.
+
+ Boost 1.69 has removed the deprecated signals library, so the otherwise
+ useless but harmless `signals` component now breaks the build.
+
+diff --git a/utilities/message_filters/CMakeLists.txt b/utilities/message_filters/CMakeLists.txt
+index 5694ac57e..d2b1477ad 100644
+--- a/utilities/message_filters/CMakeLists.txt
++++ b/utilities/message_filters/CMakeLists.txt
+@@ -13,7 +13,7 @@ catkin_package(
+ )
+ catkin_python_setup()
+
+-find_package(Boost REQUIRED COMPONENTS signals thread)
++find_package(Boost REQUIRED COMPONENTS thread)
+
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+ link_directories(${catkin_LIBRARY_DIRS})
diff --git a/dev-ros/message_filters/message_filters-1.14.3.ebuild b/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
index ec237f43cd55..48aa4d167295 100644
--- a/dev-ros/message_filters/message_filters-1.14.3.ebuild
+++ b/dev-ros/message_filters/message_filters-1.14.3-r1.ebuild
@@ -29,4 +29,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/tests.patch" )
+PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )