summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 15:58:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 16:43:53 +0100
commit3cef02d406dae860ea37b66a9fc0c1f44947402f (patch)
tree47b2c7380b2ed1fc9dfa5f69618adc70980b25d2 /dev-ros
parentdev-ros/ament_cmake_python: fix deps, add live ebuild (diff)
downloadgentoo-3cef02d406dae860ea37b66a9fc0c1f44947402f.tar.gz
gentoo-3cef02d406dae860ea37b66a9fc0c1f44947402f.tar.bz2
gentoo-3cef02d406dae860ea37b66a9fc0c1f44947402f.zip
dev-ros/ament_cmake_target_dependencies: fix deps, add live ebuild
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-0.8.1.ebuild23
-rw-r--r--dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-9999.ebuild50
2 files changed, 68 insertions, 5 deletions
diff --git a/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-0.8.1.ebuild b/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-0.8.1.ebuild
index 72c3c313f909..85658b767df9 100644
--- a/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-0.8.1.ebuild
@@ -8,24 +8,37 @@ PYTHON_COMPAT=( python{3_6,3_7} )
inherit cmake-utils python-r1
ROS_PN="ament_cmake"
-DESCRIPTION="The core of the ament buildsystem in CMake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Add defs, include dirs and libs to a target in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"
-SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
IUSE=""
DEPEND="
dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
dev-ros/ament_cmake_include_directories[${PYTHON_USEDEP}]
dev-ros/ament_cmake_libraries[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
"
RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
src_configure() {
# This is a build tool that does not install python-related files
diff --git a/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-9999.ebuild b/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-9999.ebuild
new file mode 100644
index 000000000000..85658b767df9
--- /dev/null
+++ b/dev-ros/ament_cmake_target_dependencies/ament_cmake_target_dependencies-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Add defs, include dirs and libs to a target in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_include_directories[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_libraries[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}