summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 18:41:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 18:54:36 +0200
commit4ab8a3265c1739626d74b15fb150e8916baa360c (patch)
treeb9d41e8e349f5abeac88f5d3ad2f0ccde573dc48 /dev-ros
parentdev-ros/visp_camera_calibration: Remove old (diff)
downloadgentoo-4ab8a3265c1739626d74b15fb150e8916baa360c.tar.gz
gentoo-4ab8a3265c1739626d74b15fb150e8916baa360c.tar.bz2
gentoo-4ab8a3265c1739626d74b15fb150e8916baa360c.zip
dev-ros/visp_camera_calibration: eapi7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild8
-rw-r--r--dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild
index 37777151105e..9ca3a9dedfc1 100644
--- a/dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-0.11.1.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/lagadic/vision_visp"
KEYWORDS="~amd64 ~arm"
VER_PREFIX="kinetic-"
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
inherit ros-catkin
@@ -19,13 +18,14 @@ IUSE=""
RDEPEND="
dev-ros/camera_calibration_parsers
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/roscpp
dev-ros/visp_bridge
sci-libs/ViSP:=
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
if [ "${PV#9999}" = "${PV}" ] ; then
S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
fi
diff --git a/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
index 37777151105e..9ca3a9dedfc1 100644
--- a/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
+++ b/dev-ros/visp_camera_calibration/visp_camera_calibration-9999.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/lagadic/vision_visp"
KEYWORDS="~amd64 ~arm"
VER_PREFIX="kinetic-"
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
inherit ros-catkin
@@ -19,13 +18,14 @@ IUSE=""
RDEPEND="
dev-ros/camera_calibration_parsers
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/roscpp
dev-ros/visp_bridge
sci-libs/ViSP:=
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
if [ "${PV#9999}" = "${PV}" ] ; then
S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
fi