summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 12:45:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 12:48:38 +0100
commit54a0d665365030d765830fe9a41b9f183652a30b (patch)
tree247ac39a4d62f7936f9fe84c83e1ca8aad673c50 /dev-ros
parentmedia-sound/qsampler-9999: fixed call of xdg functions (diff)
downloadgentoo-54a0d665365030d765830fe9a41b9f183652a30b.tar.gz
gentoo-54a0d665365030d765830fe9a41b9f183652a30b.tar.bz2
gentoo-54a0d665365030d765830fe9a41b9f183652a30b.zip
dev-ros/console_bridge_vendor: simplify to use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild15
-rw-r--r--dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild15
2 files changed, 6 insertions, 24 deletions
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
index e36d23f50a78..9d08355634bd 100644
--- a/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-1.2.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -31,16 +31,7 @@ DEPEND="
>=dev-libs/console_bridge-0.4.1
"
RDEPEND="${DEPEND}"
-BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}
diff --git a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
index e36d23f50a78..9d08355634bd 100644
--- a/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
+++ b/dev-ros/console_bridge_vendor/console_bridge_vendor-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -31,16 +31,7 @@ DEPEND="
>=dev-libs/console_bridge-0.4.1
"
RDEPEND="${DEPEND}"
-BDEPEND="ros-meta/ament_cmake[${PYTHON_USEDEP}]
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}