summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 08:07:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 08:25:27 +0200
commit5c06b76da032b5c78de8f3a3d99017c7707d1c72 (patch)
tree3b659a57896acce3e14e574d3b231ff5f97d408f /dev-ros
parentdev-python/rospkg: bump to 1.1.2 (diff)
downloadgentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.tar.gz
gentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.tar.bz2
gentoo-5c06b76da032b5c78de8f3a3d99017c7707d1c72.zip
dev-ros/rqt_graph: bump to 0.4.9
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
index a3f182b5d600..21093cf3471f 100644
--- a/dev-ros/rqt_graph/Manifest
+++ b/dev-ros/rqt_graph/Manifest
@@ -1,2 +1,3 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
DIST rqt_graph-0.4.8.tar.gz 15785 SHA256 db2ec3857a9576a4e7ed2b97b64aa57ae41e9d89901b5e2d504fdfc117678f37 SHA512 9e1cf0a43fef0a2dd245139abda9d08da5aeb6c78177247db8e25d8fa97a3394bf4617a4b0ad1f59af5c08cb56c1f02852b16a7dc2ee5fe11e05b2e515501314 WHIRLPOOL c73244a078ec952c06e34d63db5bb587d06a0ef732b8e17f86a49585d8e12fd02f0ba9aa58b5cc8334f417e8663b35182951fa4dd755d15fd9b2ad01b2b42ed8
+DIST rqt_graph-0.4.9.tar.gz 15857 SHA256 83b7dd7a826cd21cedde48739adbac4281968698951967b6f24fdb5de4714a3e SHA512 21d1395f272f38bb27f7549c865a9e2b4ac5d9267c50dbbaf02016b509b6fab08526c35a87f500788bad094e605d89f925baf939742e78f37d615fedcb04776e WHIRLPOOL a14a961e039ebf59dc9132d471b9a02da9b3f196085b8d0a4658e3f4c8e5153321a0da21b7a3148b8dc0eb017f6d02fcf2a4cd55e46b84e9558015b49a84ef01
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
new file mode 100644
index 000000000000..1f2bff4c39fc
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"