summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-04 10:52:29 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-04 11:12:40 +0200
commit651b00fefab57c7b295bfc8f930b5532d8db0468 (patch)
tree1f9a29445da253f73c97ee08e618e43f49fbdd60 /dev-ros
parentros-meta/rqt_common_plugins: remove old (diff)
downloadgentoo-651b00fefab57c7b295bfc8f930b5532d8db0468.tar.gz
gentoo-651b00fefab57c7b295bfc8f930b5532d8db0468.tar.bz2
gentoo-651b00fefab57c7b295bfc8f930b5532d8db0468.zip
dev-ros/urdf_tutorial: bump to 0.2.5
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/urdf_tutorial/Manifest1
-rw-r--r--dev-ros/urdf_tutorial/files/notest.patch14
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-0.2.5.ebuild23
-rw-r--r--dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild4
4 files changed, 40 insertions, 2 deletions
diff --git a/dev-ros/urdf_tutorial/Manifest b/dev-ros/urdf_tutorial/Manifest
index 30110743174a..2843b3270484 100644
--- a/dev-ros/urdf_tutorial/Manifest
+++ b/dev-ros/urdf_tutorial/Manifest
@@ -1 +1,2 @@
DIST urdf_tutorial-0.2.4.tar.gz 580617 SHA256 ac6c1d666eae7987ace46bab78dc9cc837a17462e59a80574d5441d0653cf333 SHA512 be1909b6b2f4efd5e0b846ab465d9b5b4096f729ffda7568194e4d3208604be83f7007160a767cc8f6df71edca9822e7e49e8f069e88e7b27d11690f7a17bf35 WHIRLPOOL 0b1fa28982bb5cf85d6241e8bbb75f56b88c8998dce23be0ac93d31559abb1ae563dab466673cd958bef0bfa956f43687b2b14f0d996f1583b57ea04357344cb
+DIST urdf_tutorial-0.2.5.tar.gz 866990 SHA256 c90e7ca21bb51e851f1609c853103f39711da18f79c9915cd4d5fc3f100031c2 SHA512 5de1af9cf93063996ccd3a33a88fda022ab3182c9f5cd47c0217c63ca8501bac4bcb58f358870461ffdf1b110c47dc30734886359d5d3c30afb41412155fec04 WHIRLPOOL b4aee94389a8cbd3c3d8cfbe9fdc7fa8ea4541f35540919898af9daba1adf1f2d3e138e4eb873b4cdc508a0f142842a52cad74ffa0c91c9989c273aae6955a84
diff --git a/dev-ros/urdf_tutorial/files/notest.patch b/dev-ros/urdf_tutorial/files/notest.patch
new file mode 100644
index 000000000000..63e25b65dbed
--- /dev/null
+++ b/dev-ros/urdf_tutorial/files/notest.patch
@@ -0,0 +1,14 @@
+Index: urdf_tutorial-0.2.5/CMakeLists.txt
+===================================================================
+--- urdf_tutorial-0.2.5.orig/CMakeLists.txt
++++ urdf_tutorial-0.2.5/CMakeLists.txt
+@@ -4,7 +4,9 @@ project(urdf_tutorial)
+ find_package(catkin REQUIRED roslaunch)
+ catkin_package()
+
++if(CATKIN_ENABLE_TESTING)
+ roslaunch_add_file_check(launch)
++endif()
+
+ install(DIRECTORY config images meshes launch rviz urdf
+ DESTINATION ${CATKIN_PACKAGE_SHARE_DESTINATION})
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-0.2.5.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-0.2.5.ebuild
new file mode 100644
index 000000000000..845c092ca24d
--- /dev/null
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-0.2.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf_tutorial"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="URDF tutorials"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urdf
+ dev-ros/joint_state_publisher
+ dev-ros/robot_state_publisher
+ dev-ros/rviz
+ dev-ros/xacro
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/notest.patch" )
diff --git a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
index 68caace85fb0..845c092ca24d 100644
--- a/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
+++ b/dev-ros/urdf_tutorial/urdf_tutorial-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,9 +15,9 @@ IUSE=""
RDEPEND="
dev-ros/urdf
dev-ros/joint_state_publisher
- dev-ros/pr2_description
dev-ros/robot_state_publisher
dev-ros/rviz
dev-ros/xacro
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/notest.patch" )