summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-02 11:19:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-02 11:19:14 +0100
commit6b50ed651a950ced26bd0efa7559555ea6e33416 (patch)
tree9d05b8e041c8280ad6321b5cd0b2ce4e548edc4f /dev-ros
parentnet-fs/samba: Re-added dev-libs/libaio (automagic dependency). (diff)
downloadgentoo-6b50ed651a950ced26bd0efa7559555ea6e33416.tar.gz
gentoo-6b50ed651a950ced26bd0efa7559555ea6e33416.tar.bz2
gentoo-6b50ed651a950ced26bd0efa7559555ea6e33416.zip
dev-ros/hector_pose_estimation_core: fix build with gcc6, bug #598114
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/hector_pose_estimation_core/files/gcc6.patch35
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild2
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ros/hector_pose_estimation_core/files/gcc6.patch b/dev-ros/hector_pose_estimation_core/files/gcc6.patch
new file mode 100644
index 000000000000..42862915244b
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/gcc6.patch
@@ -0,0 +1,35 @@
+Index: hector_pose_estimation_core/include/hector_pose_estimation/input.h
+===================================================================
+--- hector_pose_estimation_core.orig/include/hector_pose_estimation/input.h
++++ hector_pose_estimation_core/include/hector_pose_estimation/input.h
+@@ -79,7 +79,7 @@ public:
+ return *variance_;
+ }
+
+- virtual bool hasVariance() const { return variance_; }
++ virtual bool hasVariance() const { return variance_ != NULL; }
+ virtual Variance const &getVariance() { if (!variance_) variance_.reset(new Variance); return *variance_; }
+ virtual Variance const &getVariance() const { return *variance_; }
+ virtual Variance& variance() { if (!variance_) variance_.reset(new Variance); return *variance_; }
+Index: hector_pose_estimation_core/src/system/imu_model.cpp
+===================================================================
+--- hector_pose_estimation_core.orig/src/system/imu_model.cpp
++++ hector_pose_estimation_core/src/system/imu_model.cpp
+@@ -51,7 +51,7 @@ GyroModel::~GyroModel()
+ bool GyroModel::init(PoseEstimation& estimator, System &system, State& state)
+ {
+ bias_ = state.addSubState<3,3>(this, system.getName() + "_bias");
+- return bias_;
++ return bias_ != NULL;
+ }
+
+ void GyroModel::getPrior(State &state)
+@@ -113,7 +113,7 @@ AccelerometerModel::~AccelerometerModel(
+ bool AccelerometerModel::init(PoseEstimation& estimator, System &system, State& state)
+ {
+ bias_ = state.addSubState<3,3>(this, system.getName() + "_bias");
+- return bias_;
++ return bias_ != NULL;
+ }
+
+ void AccelerometerModel::getPrior(State &state)
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
index 3fce19f64606..63064ba7710b 100644
--- a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
@@ -27,4 +27,4 @@ RDEPEND="
"
DEPEND="${RDEPEND}
dev-cpp/eigen:3"
-PATCHES=( "${FILESDIR}/includes.patch" )
+PATCHES=( "${FILESDIR}/includes.patch" "${FILESDIR}/gcc6.patch" )