summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 13:03:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:34 +0200
commit6c27ec8620e1a8da4aa9839fa6208a745823c304 (patch)
tree9aaed91922a31733b2433383156262c8ac60d767 /dev-ros
parentdev-python/ament_package: bump to 0.9.2 (diff)
downloadgentoo-6c27ec8620e1a8da4aa9839fa6208a745823c304.tar.gz
gentoo-6c27ec8620e1a8da4aa9839fa6208a745823c304.tar.bz2
gentoo-6c27ec8620e1a8da4aa9839fa6208a745823c304.zip
dev-ros/ament_cmake_core: bump to 0.9.6
Use cmake.eclass Add python check deps Closes: https://bugs.gentoo.org/703984 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_core/Manifest1
-rw-r--r--dev-ros/ament_cmake_core/ament_cmake_core-0.9.6.ebuild46
-rw-r--r--dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild11
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-ros/ament_cmake_core/Manifest b/dev-ros/ament_cmake_core/Manifest
index ed522b74e133..613f2bd5cee8 100644
--- a/dev-ros/ament_cmake_core/Manifest
+++ b/dev-ros/ament_cmake_core/Manifest
@@ -1 +1,2 @@
DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
+DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-0.9.6.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-0.9.6.ebuild
new file mode 100644
index 000000000000..91e4b417df78
--- /dev/null
+++ b/dev-ros/ament_cmake_core/ament_cmake_core-0.9.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The core of the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-python/ament_package
+ dev-python/catkin_pkg
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild
index 6e3eac947c36..91e4b417df78 100644
--- a/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild
+++ b/dev-ros/ament_cmake_core/ament_cmake_core-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -39,3 +39,8 @@ BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}