summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 11:42:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:42:44 +0200
commit7d78ab428f86afc75371d028ec5987e7e4e11886 (patch)
tree5fdc96a636058a307d4b6b0f335151a3fe14e907 /dev-ros
parentdev-ros/gazebo_plugins: Bump to 2.5.3. (diff)
downloadgentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.tar.gz
gentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.tar.bz2
gentoo-7d78ab428f86afc75371d028ec5987e7e4e11886.zip
dev-ros/gazebo_ros: Bump to 2.5.3.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index f4649f44c43f..2cabeccb026f 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1,2 +1,3 @@
DIST gazebo_ros_pkgs-2.5.1.tar.gz 1812295 SHA256 1d78839d174790db400466b4b165a79fea50177a3fbe59291539b8bdc1876d4e SHA512 2e0faaa770abe9ff2b41d176c7a3dadaf8749f32c924ba6018b3d7dabf0fe2a1e4ffd24c840c777229a4941e7f4522bf2287288619e2c819d4fb3c10fa431c9d WHIRLPOOL 09b0c5038b21a6cfc355fed8d8d2981cb845c8d209cb89112fb6daf1694b735dd68096ca7e2f255fdc2e8ba435080df186057344c81c2ac247c28d64019dbe32
DIST gazebo_ros_pkgs-2.5.2.tar.gz 1815044 SHA256 849c541412b7312d3455827ccf386246b5bbc4d674e76ed0e9e08032026a929b SHA512 1f8b7034520712606e8389526115f0bae4084cbfdd1b5834f5c00233ae2864260cbb591512228f1519642fde860366a7b4f9602d5374817ca084494668b76bd4 WHIRLPOOL 13283cda29a4da4efb366d3074b9a55ca61b5c9e4a27b3cb467210405ed82334a849a3353f652bc6333e86e845f5845437ebaa23942a027a288fcd831fc77525
+DIST gazebo_ros_pkgs-2.5.3.tar.gz 1816954 SHA256 5c30ea914b624fb0bf1ca8bda869b9c10ce8336114e629ef19ad075320f4fca4 SHA512 9c045c0fa5be33c37017fc6abe5f307e97c8c9190a4c602e66f3dcc6435854b8c1bd863e26fc1e480c7be0bca381889677f140bd8948abe55cb468c19c636039 WHIRLPOOL 35d07adce0ab4f1accd4acf1fc11f2309776f8870abc2ec69422c60962acbb4cb1157c4e81e40517202b2573ffc6daa2a49f129c2b2c4117a886f77c433fcddd
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild
new file mode 100644
index 000000000000..870276d41866
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"