summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-23 13:27:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-23 13:28:12 +0100
commit9f224b06d4fcfe719b2881195d4673983884d483 (patch)
tree3172a23ec179daa66a6bef67246068e77e20934f /dev-ros
parentdev-ros/image_view: remove old (diff)
downloadgentoo-9f224b06d4fcfe719b2881195d4673983884d483.tar.gz
gentoo-9f224b06d4fcfe719b2881195d4673983884d483.tar.bz2
gentoo-9f224b06d4fcfe719b2881195d4673983884d483.zip
dev-ros/image_view: Backport upstream patch to build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/image_view/files/gcc6.patch44
-rw-r--r--dev-ros/image_view/image_view-1.12.19.ebuild3
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ros/image_view/files/gcc6.patch b/dev-ros/image_view/files/gcc6.patch
new file mode 100644
index 000000000000..8683c0fa980a
--- /dev/null
+++ b/dev-ros/image_view/files/gcc6.patch
@@ -0,0 +1,44 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Fri Sep 30 15:39:47 2016 +0200
+
+ address gcc6 build error
+
+ With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+ as including '-isystem /usr/include' breaks with gcc6, cf.,
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+
+ This commit addresses this issue for this package in the same way
+ it was addressed in various other ROS packages. A list of related
+ commits and pull requests is at:
+
+ https://github.com/ros/rosdistro/issues/12783
+
+ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/image_view/CMakeLists.txt b/image_view/CMakeLists.txt
+index 78b9eaa..93fabe7 100644
+--- a/image_view/CMakeLists.txt
++++ b/image_view/CMakeLists.txt
+@@ -8,9 +8,9 @@ catkin_package(CATKIN_DEPENDS dynamic_reconfigure)
+ find_package(Boost REQUIRED COMPONENTS signals thread)
+ find_package(OpenCV REQUIRED)
+
+-include_directories(SYSTEM ${Boost_INCLUDE_DIRS}
+- ${catkin_INCLUDE_DIRS}
+- ${OpenCV_INCLUDE_DIRS}
++include_directories(${Boost_INCLUDE_DIRS}
++ ${catkin_INCLUDE_DIRS}
++ ${OpenCV_INCLUDE_DIRS}
+ )
+
+ # Extra tools
+@@ -40,7 +40,7 @@ endif()
+
+ find_package(GTK2)
+ add_definitions(-DHAVE_GTK)
+-include_directories(SYSTEM ${GTK2_INCLUDE_DIRS})
++include_directories(${GTK2_INCLUDE_DIRS})
+
+ # Nodelet library
+ add_library(image_view src/nodelets/image_nodelet.cpp src/nodelets/disparity_nodelet.cpp src/nodelets/window_thread.cpp)
diff --git a/dev-ros/image_view/image_view-1.12.19.ebuild b/dev-ros/image_view/image_view-1.12.19.ebuild
index 5aabd0316e6a..1856fbbc9b97 100644
--- a/dev-ros/image_view/image_view-1.12.19.ebuild
+++ b/dev-ros/image_view/image_view-1.12.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,3 +31,4 @@ RDEPEND="
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )