summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 13:58:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:21:05 +0200
commit9f88c56a52b4c6e587764403266e1898611fae79 (patch)
tree6bd89742241ac33f3bb52d61669db003d69b637b /dev-ros
parentdev-ros/roslang: Bump to 1.15.6. (diff)
downloadgentoo-9f88c56a52b4c6e587764403266e1898611fae79.tar.gz
gentoo-9f88c56a52b4c6e587764403266e1898611fae79.tar.bz2
gentoo-9f88c56a52b4c6e587764403266e1898611fae79.zip
dev-ros/roslib: Bump to 1.15.6.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/roslib/Manifest1
-rw-r--r--dev-ros/roslib/roslib-1.15.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roslib/Manifest b/dev-ros/roslib/Manifest
index 8c4e0fcd5d4e..dfc124affc62 100644
--- a/dev-ros/roslib/Manifest
+++ b/dev-ros/roslib/Manifest
@@ -1 +1,2 @@
DIST ros-1.15.5.tar.gz 178252 BLAKE2B 2e96f550ee6d9e049db4a69464db0bf948f2baf8ea50b2105ac19dcd758e4fc57cb011529e28cd9058ccb4adcbcf087e6295f35e6f9c511f5f33c3ddbe27c2db SHA512 d526e267faf231c0c9153614a24f05294b648595bda6d99ea937ca3cca70b2784b26c3c62f9b4830322adbd17d8e151be314c7301b753450450c5c38527d48d3
+DIST ros-1.15.6.tar.gz 178270 BLAKE2B dccadd6c3b59b54d732d94a173c40e940f2e7effad5bc8f835bbf56f2b7f3d6b7a80183d1e4826edd566697ffc22ae77b5b75d792493220c0fc04603b3c33f85 SHA512 740727c68113d7a84583a85f4fc3f575aea05067d1aa3b96d5636d3454dba09a4730413c92f49cb7800f26bae15ab02496bd5f91f964b28511e8b8cd3cb116a6
diff --git a/dev-ros/roslib/roslib-1.15.6.ebuild b/dev-ros/roslib/roslib-1.15.6.ebuild
new file mode 100644
index 000000000000..bde355c582b7
--- /dev/null
+++ b/dev-ros/roslib/roslib-1.15.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Base dependencies and support libraries for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep ">=dev-python/rospkg-1.0.37[\${PYTHON_USEDEP}]")
+ dev-libs/boost:=[threads]
+ dev-ros/rospack
+ dev-ros/ros_environment
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"