summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-06 09:57:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-06 10:21:07 +0200
commita389562725213cfb4287e158d289feb413aba908 (patch)
tree46cb5e6943e49b0359d479e20836c2cdea74b7c8 /dev-ros
parentdev-python/rosdistro: bump to 0.6.2 (diff)
downloadgentoo-a389562725213cfb4287e158d289feb413aba908.tar.gz
gentoo-a389562725213cfb4287e158d289feb413aba908.tar.bz2
gentoo-a389562725213cfb4287e158d289feb413aba908.zip
dev-ros/unique_id: Bump to 1.0.6.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/unique_id/Manifest1
-rw-r--r--dev-ros/unique_id/unique_id-1.0.6.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/unique_id/Manifest b/dev-ros/unique_id/Manifest
index 3f304f48095a..dc314b88872f 100644
--- a/dev-ros/unique_id/Manifest
+++ b/dev-ros/unique_id/Manifest
@@ -1 +1,2 @@
DIST unique_identifier-1.0.5.tar.gz 12252 SHA256 70f3fc1e8b81ce2a80383fe1bec69dd0760913852a78ff1d010e6a1c2baa1d3c SHA512 0a12fe42346d83813eed78a369afeec171df928abad2cfa804cb314907fa43a3edad3cef5efe51b3223f819a80ac1633f069e7e0bd721efc9f487a1089d160d3 WHIRLPOOL 2b18cb09845254b88026ef69739203a66438563094375e5cd711239af90f157f1727deb82252c719fd5b78a372c8877771c42bbd30c360acc8c943676a343197
+DIST unique_identifier-1.0.6.tar.gz 12305 SHA256 e376df28058d69da4c3c5fce4ef5d3cc24518ed9b64a181055ff86a2fc11b832 SHA512 d81409786a311fd1d23937fd24bf0365920f6b9cd7b4ba9803935844c0dab0a1765b2790f88673fe8fffea70ff13161ddadc7644bc8d39e3f0c255007b267156 WHIRLPOOL 5242ebcaf5c5cf8b6f16cfd9e1b09936f8af646d3ea629d856387759ccece0f69bc87e6abfc34ba48c199b266ca08bee960fee46dc4adb890ce952fb401c524c
diff --git a/dev-ros/unique_id/unique_id-1.0.6.ebuild b/dev-ros/unique_id/unique_id-1.0.6.ebuild
new file mode 100644
index 000000000000..612f302dfc98
--- /dev/null
+++ b/dev-ros/unique_id/unique_id-1.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Python and C++ interfaces for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"