summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 17:55:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:32 +0200
commita4615e34b91cb694bba2742e977c9013ca601983 (patch)
treeaeeb59dead0ff3d180cef3ce61dd15e825dd42a1 /dev-ros
parentdev-ros/diagnostic_common_diagnostics: convert to python-single-r1 (diff)
downloadgentoo-a4615e34b91cb694bba2742e977c9013ca601983.tar.gz
gentoo-a4615e34b91cb694bba2742e977c9013ca601983.tar.bz2
gentoo-a4615e34b91cb694bba2742e977c9013ca601983.zip
dev-ros/diagnostic_analysis: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild8
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
index bf479c375c49..fb4c8e93adad 100644
--- a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.9.4.ebuild
@@ -15,9 +15,9 @@ IUSE=""
RDEPEND="
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )"
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild
index bf479c375c49..fb4c8e93adad 100644
--- a/dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-9999.ebuild
@@ -15,9 +15,9 @@ IUSE=""
RDEPEND="
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rosbag[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )"