summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 19:26:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 19:30:58 +0200
commita8132889bbb224d3ebc6bdf7ef7c8e1a47a0f14b (patch)
treef7b2ce69e39279e75c4cf8ba119df6e6e3280947 /dev-ros
parentdev-ros/turtlesim: Remove old (diff)
downloadgentoo-a8132889bbb224d3ebc6bdf7ef7c8e1a47a0f14b.tar.gz
gentoo-a8132889bbb224d3ebc6bdf7ef7c8e1a47a0f14b.tar.bz2
gentoo-a8132889bbb224d3ebc6bdf7ef7c8e1a47a0f14b.zip
dev-ros/turtlesim: eapi7
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/turtlesim/turtlesim-0.10.0.ebuild6
-rw-r--r--dev-ros/turtlesim/turtlesim-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-ros/turtlesim/turtlesim-0.10.0.ebuild b/dev-ros/turtlesim/turtlesim-0.10.0.ebuild
index fcc2e65dc1f2..1f53e6c46ac3 100644
--- a/dev-ros/turtlesim/turtlesim-0.10.0.ebuild
+++ b/dev-ros/turtlesim/turtlesim-0.10.0.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_tutorials"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/std_srvs dev-ros/geometry_msgs"
inherit ros-catkin
@@ -26,7 +25,8 @@ RDEPEND="
dev-ros/roscpp_serialization
dev-ros/roslib
dev-ros/rostime
+"
+DEPEND="${RDEPEND}
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/turtlesim/turtlesim-9999.ebuild b/dev-ros/turtlesim/turtlesim-9999.ebuild
index e2e296b12f34..1f53e6c46ac3 100644
--- a/dev-ros/turtlesim/turtlesim-9999.ebuild
+++ b/dev-ros/turtlesim/turtlesim-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_tutorials"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/std_srvs dev-ros/geometry_msgs"
inherit ros-catkin
@@ -26,7 +25,8 @@ RDEPEND="
dev-ros/roscpp_serialization
dev-ros/roslib
dev-ros/rostime
+"
+DEPEND="${RDEPEND}
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"