summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-24 11:17:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:29:38 +0300
commita9ed58a03a00a507d705f6e04d75642426faac10 (patch)
tree1d7ad934673a19c7dd0e1d1b9e8fd1974c4dc47d /dev-ros
parentdev-ros/ament_pep257: enable py3.9, enable py3.10 (diff)
downloadgentoo-a9ed58a03a00a507d705f6e04d75642426faac10.tar.gz
gentoo-a9ed58a03a00a507d705f6e04d75642426faac10.tar.bz2
gentoo-a9ed58a03a00a507d705f6e04d75642426faac10.zip
dev-ros/ament_copyright: enable py3.9, enable py3.10
passes tests Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild24
-rw-r--r--dev-ros/ament_copyright/ament_copyright-9999.ebuild24
2 files changed, 12 insertions, 36 deletions
diff --git a/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild b/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild
index dfdc3192ac68..74abd98c7e6a 100644
--- a/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild
+++ b/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The ability to check source files for copyright and license information."
@@ -24,29 +24,17 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
RDEPEND="
dev-ros/ament_lint
dev-python/importlib_metadata[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
-
-distutils_enable_tests pytest
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest
diff --git a/dev-ros/ament_copyright/ament_copyright-9999.ebuild b/dev-ros/ament_copyright/ament_copyright-9999.ebuild
index dfdc3192ac68..74abd98c7e6a 100644
--- a/dev-ros/ament_copyright/ament_copyright-9999.ebuild
+++ b/dev-ros/ament_copyright/ament_copyright-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The ability to check source files for copyright and license information."
@@ -24,29 +24,17 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
RDEPEND="
dev-ros/ament_lint
dev-python/importlib_metadata[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
-
-distutils_enable_tests pytest
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests --install pytest