summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 16:45:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:01:44 +0200
commitc3cd17886f876a75371ab718d19c28d3002eda4a (patch)
tree51eb42dd5f47f2607bc36b699a46f3415fdb05e1 /dev-ros
parentdev-ros/python_qt_binding: Remove old (diff)
downloadgentoo-c3cd17886f876a75371ab718d19c28d3002eda4a.tar.gz
gentoo-c3cd17886f876a75371ab718d19c28d3002eda4a.tar.bz2
gentoo-c3cd17886f876a75371ab718d19c28d3002eda4a.zip
dev-ros/python_qt_binding: bump to 0.3.5
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/python_qt_binding/Manifest1
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
index 4ee243547705..5cdc0055b727 100644
--- a/dev-ros/python_qt_binding/Manifest
+++ b/dev-ros/python_qt_binding/Manifest
@@ -1 +1,2 @@
DIST python_qt_binding-0.3.4.tar.gz 12255 BLAKE2B bc72aa806098d460e5b884bde7664f295399555d96e10b66791e59a26d1e61dd22aabecf9b40b5d14f61c2c906c18ff3fe2cd03de6108d7d9c2c649d553ab09d SHA512 df5fc2c6a744e66d0c03089e15ce4cfb3890d8fd67d826a3832d22cf99de235e18720c59f737c3ddacefb02dac5571d64042dd862c10ea4c44835063037eb533
+DIST python_qt_binding-0.3.5.tar.gz 12412 BLAKE2B ee2f2537bb1ddceb5cce0ca1963e042d10e5d011cffac25caba1a714c992d975413b7e1c4a23d5472567d4e214f482414dcfc56d499fcbcb0bd5559d7670b484 SHA512 a54ce90008d0893f236533cdda7d3520db264ba3e66b6edf18bac0d6e97975823e3900d1f265a7459813c823c9fc0bce7bb12570de1f8101b588954adeb073b4
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild
new file mode 100644
index 000000000000..5309c2893fbe
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"