summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:00:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:29 +0200
commitc92666b2376bb3273e440312d61a342facd0345b (patch)
tree24f720dec9a649688bb51b128c73ee4e25973028 /dev-ros
parentdev-ros/test_rosbag: Initial import. Ebuild by me. (diff)
downloadgentoo-c92666b2376bb3273e440312d61a342facd0345b.tar.gz
gentoo-c92666b2376bb3273e440312d61a342facd0345b.tar.bz2
gentoo-c92666b2376bb3273e440312d61a342facd0345b.zip
dev-ros/test_rosbag_storage: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/test_rosbag_storage/Manifest1
-rw-r--r--dev-ros/test_rosbag_storage/metadata.xml5
-rw-r--r--dev-ros/test_rosbag_storage/test_rosbag_storage-1.11.14.ebuild23
-rw-r--r--dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag_storage/Manifest b/dev-ros/test_rosbag_storage/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/test_rosbag_storage/metadata.xml b/dev-ros/test_rosbag_storage/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/test_rosbag_storage/test_rosbag_storage-1.11.14.ebuild b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.11.14.ebuild
new file mode 100644
index 000000000000..1bdd56f7c94a
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.11.14.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag_storage"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rosbag_storage
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild b/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild
new file mode 100644
index 000000000000..1bdd56f7c94a
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/test_rosbag_storage-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag_storage"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rosbag_storage
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ test? ( dev-cpp/gtest )"