summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-02 10:25:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-02 11:33:27 +0200
commitc94f005025020744968d67db041814102cd34e81 (patch)
tree599dd5507478373f7b82dc7232bd8345026afd50 /dev-ros
parentdev-ros/rqt_moveit: remove old (diff)
downloadgentoo-c94f005025020744968d67db041814102cd34e81.tar.gz
gentoo-c94f005025020744968d67db041814102cd34e81.tar.bz2
gentoo-c94f005025020744968d67db041814102cd34e81.zip
dev-ros/rqt_moveit: bump to 0.5.7 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_moveit/Manifest1
-rw-r--r--dev-ros/rqt_moveit/metadata.xml2
-rw-r--r--dev-ros/rqt_moveit/rqt_moveit-0.5.7.ebuild26
-rw-r--r--dev-ros/rqt_moveit/rqt_moveit-9999.ebuild5
4 files changed, 30 insertions, 4 deletions
diff --git a/dev-ros/rqt_moveit/Manifest b/dev-ros/rqt_moveit/Manifest
index bb0da5c3c13b..65d2c843db91 100644
--- a/dev-ros/rqt_moveit/Manifest
+++ b/dev-ros/rqt_moveit/Manifest
@@ -1 +1,2 @@
+DIST rqt_moveit-0.5.7.tar.gz 8000 SHA256 80430ab344e096ae32caa505fb47f33ad52d77a83578ccb19950d097dee85e06 SHA512 3103723389aa9ff891d245fbdf1e7eb157973dee25e4ff2530d147bf72385dcec716418db1a32ef0a2bcaf0940cfa36e95334293cc93baa1c6e6c97dabe2e403 WHIRLPOOL 680731e4cdcfa026d40daed07cfea9966b8fad62daf5313d73886edd514c4a129c00e55db1eedcafe8295a9315622bab0fa154f1bde455a2f815fa0026dfa270
DIST rqt_robot_plugins-0.5.6.tar.gz 2107696 SHA256 d5f1b509df54b253d3b2952560e8dc5e764c3259b0e9dcff08541e27ac9fed71 SHA512 871f660e22afafd510e34984b94d2530bc3314db194c06ff458430e15b1183a60147289e9544a5fb070665a3c83034cbcccefe2f820e62f091c3bbc0edfd0a51 WHIRLPOOL a90882b1e762f5e53b7ce7ff92695ba8eb63242b53304a08c928f2667ceb206cfda72e64d81b73d1d951e6b92cb5f16327528846f6b54e28b2acaf898424a664
diff --git a/dev-ros/rqt_moveit/metadata.xml b/dev-ros/rqt_moveit/metadata.xml
index 70d1993e2855..a4630415c383 100644
--- a/dev-ros/rqt_moveit/metadata.xml
+++ b/dev-ros/rqt_moveit/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_robot_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_moveit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_moveit/rqt_moveit-0.5.7.ebuild b/dev-ros/rqt_moveit/rqt_moveit-0.5.7.ebuild
new file mode 100644
index 000000000000..11c6884465d0
--- /dev/null
+++ b/dev-ros/rqt_moveit/rqt_moveit-0.5.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_moveit"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Assists monitoring tasks for MoveIt! motion planner"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_topic[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild b/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
index 501f5faac80e..11c6884465d0 100644
--- a/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
+++ b/dev-ros/rqt_moveit/rqt_moveit-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_moveit"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin