summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-07-18 21:39:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-07-18 21:39:17 +0200
commitd55f21128a02fe4f58019ad70c7d5d0b6a40069b (patch)
tree384d51aa880a1d4deec640c3c48eda87d83c7f61 /dev-ros
parentdev-ros/tf2: Remove old (diff)
downloadgentoo-d55f21128a02fe4f58019ad70c7d5d0b6a40069b.tar.gz
gentoo-d55f21128a02fe4f58019ad70c7d5d0b6a40069b.tar.bz2
gentoo-d55f21128a02fe4f58019ad70c7d5d0b6a40069b.zip
dev-ros/tf2: fix build with boost 1.70.
Thanks to: Victor Mataré Closes: https://bugs.gentoo.org/689724 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf2/files/boost.patch26
-rw-r--r--dev-ros/tf2/tf2-0.6.5-r1.ebuild (renamed from dev-ros/tf2/tf2-0.6.5.ebuild)3
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ros/tf2/files/boost.patch b/dev-ros/tf2/files/boost.patch
new file mode 100644
index 000000000000..5f87149ee31e
--- /dev/null
+++ b/dev-ros/tf2/files/boost.patch
@@ -0,0 +1,26 @@
+commit 6223549e4d5e1d442a9cfb8e8c7334bcc62c1662
+Author: Maarten de Vries <maarten@de-vri.es>
+Date: Thu Jan 17 16:00:14 2019 +0100
+
+ Remove `signals` from find_package(Boost COMPONENTS ...).
+
+ tf2 is using signals2, which is not the same library.
+ Additionally, signals2 has always been header only, and header only
+ libraries must not be listed in find_package.
+
+ Boost 1.69 removed the old signals library entirely, so the otherwise
+ useless `COMPONENTS signals` actually breaks the build.
+
+diff --git a/tf2/CMakeLists.txt b/tf2/CMakeLists.txt
+index 9ffb17a..7a6da34 100644
+--- a/tf2/CMakeLists.txt
++++ b/tf2/CMakeLists.txt
+@@ -3,7 +3,7 @@ project(tf2)
+
+ find_package(console_bridge REQUIRED)
+ find_package(catkin REQUIRED COMPONENTS geometry_msgs rostime tf2_msgs)
+-find_package(Boost REQUIRED COMPONENTS signals system thread)
++find_package(Boost REQUIRED COMPONENTS system thread)
+
+ catkin_package(
+ INCLUDE_DIRS include
diff --git a/dev-ros/tf2/tf2-0.6.5.ebuild b/dev-ros/tf2/tf2-0.6.5-r1.ebuild
index 102478eb1ac6..826acc9420ad 100644
--- a/dev-ros/tf2/tf2-0.6.5.ebuild
+++ b/dev-ros/tf2/tf2-0.6.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -23,3 +23,4 @@ RDEPEND="
DEPEND="${RDEPEND}
test? ( dev-ros/roscpp )
"
+PATCHES=( "${FILESDIR}/boost.patch" )