summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 13:45:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 13:45:44 +0200
commitdb6511c262aa5bbae4b416dff6d1d0d337fe47e2 (patch)
tree2b8efef292807212c80911c70ee6626a1978cc25 /dev-ros
parentdev-ros/mk: Initial import. Ebuild by me. (diff)
downloadgentoo-db6511c262aa5bbae4b416dff6d1d0d337fe47e2.tar.gz
gentoo-db6511c262aa5bbae4b416dff6d1d0d337fe47e2.tar.bz2
gentoo-db6511c262aa5bbae4b416dff6d1d0d337fe47e2.zip
dev-ros/rosbash: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosbash/Manifest1
-rw-r--r--dev-ros/rosbash/files/catkin_prefix.patch13
-rw-r--r--dev-ros/rosbash/metadata.xml5
-rw-r--r--dev-ros/rosbash/rosbash-1.12.3.ebuild20
-rw-r--r--dev-ros/rosbash/rosbash-9999.ebuild20
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-ros/rosbash/Manifest b/dev-ros/rosbash/Manifest
new file mode 100644
index 000000000000..02c7ccc4a2ae
--- /dev/null
+++ b/dev-ros/rosbash/Manifest
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/rosbash/files/catkin_prefix.patch b/dev-ros/rosbash/files/catkin_prefix.patch
new file mode 100644
index 000000000000..fce54f548856
--- /dev/null
+++ b/dev-ros/rosbash/files/catkin_prefix.patch
@@ -0,0 +1,13 @@
+Index: rosbash/scripts/rosrun
+===================================================================
+--- rosbash.orig/scripts/rosrun
++++ rosbash/scripts/rosrun
+@@ -47,7 +47,7 @@ case $2 in
+ ;;
+ esac
+
+-if [[ -n $CMAKE_PREFIX_PATH ]]; then
++if [[ -n $CMAKE_PREFIX_PATH || -n $CATKIN_PREFIX_PATH ]]; then
+ catkin_package_libexec_dir=`catkin_find --without-underlays --libexec --share $1 2> /dev/null`
+ debug "Looking in catkin libexec dir: $catkin_package_libexec_dir"
+ fi
diff --git a/dev-ros/rosbash/metadata.xml b/dev-ros/rosbash/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosbash/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosbash/rosbash-1.12.3.ebuild b/dev-ros/rosbash/rosbash-1.12.3.ebuild
new file mode 100644
index 000000000000..300eb4bfbfa5
--- /dev/null
+++ b/dev-ros/rosbash/rosbash-1.12.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Assorted shell commands for using ros with bash"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
diff --git a/dev-ros/rosbash/rosbash-9999.ebuild b/dev-ros/rosbash/rosbash-9999.ebuild
new file mode 100644
index 000000000000..300eb4bfbfa5
--- /dev/null
+++ b/dev-ros/rosbash/rosbash-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Assorted shell commands for using ros with bash"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )