summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-30 11:23:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-09-01 13:18:37 +0200
commitdcc2896805593deb7026afb335ecffe116b98092 (patch)
treedbd47275ad06c0f3ef030290a2a060e9ad3bb207 /dev-ros
parentdev-ros/imu_complementary_filter: initial import (diff)
downloadgentoo-dcc2896805593deb7026afb335ecffe116b98092.tar.gz
gentoo-dcc2896805593deb7026afb335ecffe116b98092.tar.bz2
gentoo-dcc2896805593deb7026afb335ecffe116b98092.zip
dev-ros/imu_filter_madgwick: initial import
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/imu_filter_madgwick/Manifest1
-rw-r--r--dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5.ebuild32
-rw-r--r--dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild32
-rw-r--r--dev-ros/imu_filter_madgwick/metadata.xml11
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-ros/imu_filter_madgwick/Manifest b/dev-ros/imu_filter_madgwick/Manifest
new file mode 100644
index 000000000000..82f6f559d84a
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/Manifest
@@ -0,0 +1 @@
+DIST imu_tools-1.1.5.tar.gz 1653083 SHA256 845d0c0dfa262223e7aeb5a4ed31c92865fd5fbc30eda04dd822a2c89e81e3e0 SHA512 5009884852c71d6bb1b6c2be2f30ed333eca2ac6a7f29d02cb8f0821c0b95a33dd3b09049c4c4eeb1416fb0eb5dc454b3c6d36c2c24303f37c0d1d2c0c2d906a WHIRLPOOL 2caf1b9cf671081051a2475d019802c8fb312a2e8ad668e0cda2a259778f0ef548e3967233daeefa14c5630c4b13fddde6e0ac4d42b5b7424bf156eac0443964
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5.ebuild
new file mode 100644
index 000000000000..bf02045b5978
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-ros/pluginlib
+ dev-ros/message_filters
+ dev-ros/dynamic_reconfigure
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosunit )
+"
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild
new file mode 100644
index 000000000000..bf02045b5978
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-ros/pluginlib
+ dev-ros/message_filters
+ dev-ros/dynamic_reconfigure
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosunit )
+"
diff --git a/dev-ros/imu_filter_madgwick/metadata.xml b/dev-ros/imu_filter_madgwick/metadata.xml
new file mode 100644
index 000000000000..0be33667fd34
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ccny-ros-pkg/imu_tools</remote-id>
+ </upstream>
+</pkgmetadata>