summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 12:24:11 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 16:33:10 +0100
commitdd1fb11c81d24566b63c72b8dc04cd46cece2183 (patch)
tree2b326c75bbbe570eee609d277c3ba8ecac366047 /dev-ros
parentros-meta/common_msgs: Bump to 1.13.1. (diff)
downloadgentoo-dd1fb11c81d24566b63c72b8dc04cd46cece2183.tar.gz
gentoo-dd1fb11c81d24566b63c72b8dc04cd46cece2183.tar.bz2
gentoo-dd1fb11c81d24566b63c72b8dc04cd46cece2183.zip
dev-ros/diagnostic_aggregator: Bump to 1.10.3.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/diagnostic_aggregator/Manifest1
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_aggregator/Manifest b/dev-ros/diagnostic_aggregator/Manifest
index 4c635863e79d..2006464688a2 100644
--- a/dev-ros/diagnostic_aggregator/Manifest
+++ b/dev-ros/diagnostic_aggregator/Manifest
@@ -1,2 +1,3 @@
DIST diagnostics-1.10.1.tar.gz 536607 BLAKE2B 6a69163fbf60820839f1fc7071b6ea9df7b70cc2979b42648ac56d0acce820af69595b2a9e4d11b9752d4d85bd19276ccfcb6a57a523e7d69354fbc64414fec4 SHA512 a45d41a0ba3b879ab3228bc3d3152cd59d7145b96f9a5b1798eb1d9aaba8dbd6234ec3692c1a84289d0f543eed3adb0ca4dcbd1f1b6ceaef54af7866e1ad9ee7
DIST diagnostics-1.10.2.tar.gz 536910 BLAKE2B da4de61798d0022114573ca7360f48afe0a7b62f56ac2e9830182dfd0cdaf2f7985b549807028360d8edd97ec3630465eef0d02c51333ffedf0809f235a11f26 SHA512 5a88cfe6f2bc71ae71e3d7aad6c83c6ac17fb2e072b8ba1ba97b86cb8e6f7373ba2c4b6889d0253f062119c86459880485b1afc682747f91c2eb7acdb9e71d3c
+DIST diagnostics-1.10.3.tar.gz 537295 BLAKE2B be2937c7bc537eff5c4ffd04ffcd92734626d6563c0392f645af2a6a8b2937d08157168ce12248b63316b14b5ca11e78219cb0812cf02b63c79a6cc516e080c0 SHA512 7f074f8ad789e7a07323984fa79766ae4a8ce75faf99ce31549ef97ddb2eb3b37f473878cc23557b61a0f8650582db232fe69f901c48bd2b479d42166055bcd7
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.3.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.3.ebuild
new file mode 100644
index 000000000000..b43991e89535
--- /dev/null
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-1.10.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates ROS diagnostics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/pluginlib:=
+ dev-libs/tinyxml2:=
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/rostest
+ dev-ros/xmlrpcpp
+ dev-ros/bondcpp
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}