summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-23 16:03:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-23 17:18:57 +0200
commite793b67b244cb29fdeafd0b13d3961d02c84b719 (patch)
treedf8672ff2268f7cf3a73c233f25e4c3b2140af65 /dev-ros
parentdev-ros/ament_cmake_xmllint: initial import (diff)
downloadgentoo-e793b67b244cb29fdeafd0b13d3961d02c84b719.tar.gz
gentoo-e793b67b244cb29fdeafd0b13d3961d02c84b719.tar.bz2
gentoo-e793b67b244cb29fdeafd0b13d3961d02c84b719.zip
dev-ros/poco_vendor: fix python deps
migrate to cmake eclass add tests on live ebuild Closes: https://bugs.gentoo.org/708572 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild14
-rw-r--r--dev-ros/poco_vendor/poco_vendor-9999.ebuild29
2 files changed, 34 insertions, 9 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
index b6214810f35f..5e44119b2a2b 100644
--- a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -28,10 +28,16 @@ fi
IUSE=""
DEPEND="
- dev-libs/poco
+ >=dev-libs/poco-1.6.1
+ dev-libs/libpcre
+ sys-libs/zlib
"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
index b6214810f35f..c6061e692b31 100644
--- a/dev-ros/poco_vendor/poco_vendor-9999.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python{3_7,3_8} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
@@ -25,13 +25,32 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
+IUSE="test"
DEPEND="
- dev-libs/poco
+ >=dev-libs/poco-1.6.1
+ dev-libs/libpcre
+ sys-libs/zlib
"
RDEPEND="${DEPEND}"
BDEPEND="
$(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ test? (
+ dev-ros/ament_cmake_copyright
+ dev-ros/ament_cmake_lint_cmake
+ dev-ros/ament_cmake_xmllint
+ dev-ros/ament_cmake_test
+ )
${PYTHON_DEPS}
"
+
+python_check_deps() {
+ has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ )
+ cmake_src_configure
+}