summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-01 12:28:14 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-01 12:39:00 +0200
commitecb111642777080475d19b1616236da7dd980fdf (patch)
treef46768c36cb62132cad9f683fe3c2565e4415e33 /dev-ros
parentdev-ros/sound_play: update deps to gst 1.0 (diff)
downloadgentoo-ecb111642777080475d19b1616236da7dd980fdf.tar.gz
gentoo-ecb111642777080475d19b1616236da7dd980fdf.tar.bz2
gentoo-ecb111642777080475d19b1616236da7dd980fdf.zip
dev-ros/audio_capture: Bump to 0.3.1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/audio_capture/Manifest1
-rw-r--r--dev-ros/audio_capture/audio_capture-0.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/audio_capture/Manifest b/dev-ros/audio_capture/Manifest
index e02eba370547..45ff6e1bd061 100644
--- a/dev-ros/audio_capture/Manifest
+++ b/dev-ros/audio_capture/Manifest
@@ -1 +1,2 @@
DIST audio_common-0.2.12.tar.gz 182493 SHA256 c1cdb8cbf999020fb6c97f45de1ddb39fc4712dd7cf48e6a296e5b3a8695d336 SHA512 0d0b4814ad58e34ed0c605425f648c7bc2bc43e57ff2b44b23862bfc6f8ad3381b7aac2fb365b5c8194248ce769a33d5dd01ddd0add87303ce3fd6fcfd63f267 WHIRLPOOL cbdaba77dd6a765ebb99bd51c15ffd5baca253cf1a243200c6985dd602e58afd311c6af17f001f6da35346e51275a49388e23a89759448ae5e03bd1db5ade4c3
+DIST audio_common-0.3.1.tar.gz 184749 SHA256 6845d7d1449e62b13c5e2f8c33505f6759cb947cdd2dc300537ca499fc862cb8 SHA512 3accd7d0ff91ce70c643747ae0b4db4c11bbd6b93dda02c1934d23a900b6bf286e72461e296fe1e0d49ebadd99c3ca1b042db8feddc9cca2ae70a0caccea7147 WHIRLPOOL dfa93bba077172912e47b1f6a86b2b717b2187a6e3461b95b26a2c59da1a26d23180248968dbc6c33b645047dfe2262d6e99175efcc3c9a52b25538072c9f64a
diff --git a/dev-ros/audio_capture/audio_capture-0.3.1.ebuild b/dev-ros/audio_capture/audio_capture-0.3.1.ebuild
new file mode 100644
index 000000000000..4b64400bdefb
--- /dev/null
+++ b/dev-ros/audio_capture/audio_capture-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transports audio from a source to a destination"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-plugins/gst-plugins-lame:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0
+"