summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-10 15:36:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-10 15:36:04 +0200
commitf3d9d4f3f2c1f6b943a20c9cf11a94921535c0ca (patch)
tree1e76f93724698369f40ba91a8966d79008f87de5 /dev-ros
parentdev-ros/gazebo_msgs: Bump to 2.5.6. (diff)
downloadgentoo-f3d9d4f3f2c1f6b943a20c9cf11a94921535c0ca.tar.gz
gentoo-f3d9d4f3f2c1f6b943a20c9cf11a94921535c0ca.tar.bz2
gentoo-f3d9d4f3f2c1f6b943a20c9cf11a94921535c0ca.zip
dev-ros/gazebo_plugins: Bump to 2.5.6.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/gazebo_plugins/Manifest1
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-2.5.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/gazebo_plugins/Manifest b/dev-ros/gazebo_plugins/Manifest
index 93d28a66b01c..886366811e67 100644
--- a/dev-ros/gazebo_plugins/Manifest
+++ b/dev-ros/gazebo_plugins/Manifest
@@ -1,2 +1,3 @@
DIST gazebo_ros_pkgs-2.5.2.tar.gz 1815044 SHA256 849c541412b7312d3455827ccf386246b5bbc4d674e76ed0e9e08032026a929b SHA512 1f8b7034520712606e8389526115f0bae4084cbfdd1b5834f5c00233ae2864260cbb591512228f1519642fde860366a7b4f9602d5374817ca084494668b76bd4 WHIRLPOOL 13283cda29a4da4efb366d3074b9a55ca61b5c9e4a27b3cb467210405ed82334a849a3353f652bc6333e86e845f5845437ebaa23942a027a288fcd831fc77525
DIST gazebo_ros_pkgs-2.5.3.tar.gz 1816954 SHA256 5c30ea914b624fb0bf1ca8bda869b9c10ce8336114e629ef19ad075320f4fca4 SHA512 9c045c0fa5be33c37017fc6abe5f307e97c8c9190a4c602e66f3dcc6435854b8c1bd863e26fc1e480c7be0bca381889677f140bd8948abe55cb468c19c636039 WHIRLPOOL 35d07adce0ab4f1accd4acf1fc11f2309776f8870abc2ec69422c60962acbb4cb1157c4e81e40517202b2573ffc6daa2a49f129c2b2c4117a886f77c433fcddd
+DIST gazebo_ros_pkgs-2.5.6.tar.gz 1821635 SHA256 ff8da02dd8c58a92deddcff9bf67c3d9583cb0fac0e6435774989f7451c939c8 SHA512 7c815de70d5e3a27f4796de2d0cebbbbde85dc55f90da3d2db6ea650a4c82bd333f3f1d5aaf3a6d9d6d1101fd54bf589f97d02c6d89ba5e78c72d79a90e0aa10 WHIRLPOOL 17b9caa8a5aa17284d6a0409064b0ec8300877f2a1ec701707e787d079a612b80d0a7758822e99d64a5d125bd32066fe8b2809fbace4facfa5490af4a8d9ac32
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.5.6.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.5.6.ebuild
new file mode 100644
index 000000000000..2c0abf6a639e
--- /dev/null
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-2.5.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/nodelet
+ dev-ros/angles
+ dev-ros/std_srvs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/urdf
+ dev-ros/tf
+ dev-ros/tf2_ros
+ dev-ros/dynamic_reconfigure
+ dev-ros/driver_base
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pcl_conversions
+ dev-ros/image_transport
+ dev-ros/rosconsole
+ dev-ros/cv_bridge
+ dev-ros/polled_camera
+ dev-ros/diagnostic_updater
+ dev-ros/camera_info_manager
+ dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/libxml2
+ >=sci-electronics/gazebo-7:=
+ dev-games/ogre
+ sci-libs/pcl
+ dev-libs/boost:=
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"