summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-03-14 08:31:27 +0100
committerHans de Graaff <graaff@gentoo.org>2019-03-14 08:31:27 +0100
commitfccd824175f862967c20727fcd08fbcea1c4a133 (patch)
tree4ce501a9a3b5bd1a30d5b8bbd69a16e47a05a263 /dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild
parentdev-ruby/actionpack: add 4.2.11.1 (diff)
downloadgentoo-fccd824175f862967c20727fcd08fbcea1c4a133.tar.gz
gentoo-fccd824175f862967c20727fcd08fbcea1c4a133.tar.bz2
gentoo-fccd824175f862967c20727fcd08fbcea1c4a133.zip
dev-ruby/actionmailer: add 4.2.11.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild b/dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild
new file mode 100644
index 000000000000..aeb691646830
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.2.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:* =dev-ruby/mail-2*:*
+ >=dev-ruby/rails-dom-testing-1.0.5:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|mime-types\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/rake/ s/12.3/12.4/ ; /dalli/ s/2.7.7/2.7.10/' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}