summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-03-29 07:50:32 +0100
committerHans de Graaff <graaff@gentoo.org>2019-03-29 07:58:11 +0100
commiteb387574ba82a9eaf1fa72f36851748ac56ddcbe (patch)
tree73cef7bb211bc25f2344f21b781a1edc2e98405d /dev-ruby/actionpack/actionpack-5.1.7.ebuild
parentdev-ruby/actionview: add 5.1.7 (diff)
downloadgentoo-eb387574ba82a9eaf1fa72f36851748ac56ddcbe.tar.gz
gentoo-eb387574ba82a9eaf1fa72f36851748ac56ddcbe.tar.bz2
gentoo-eb387574ba82a9eaf1fa72f36851748ac56ddcbe.zip
dev-ruby/actionpack: add 5.1.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/actionpack/actionpack-5.1.7.ebuild')
-rw-r--r--dev-ruby/actionpack/actionpack-5.1.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/actionpack/actionpack-5.1.7.ebuild b/dev-ruby/actionpack/actionpack-5.1.7.ebuild
new file mode 100644
index 000000000000..910c4930770a
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-5.1.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ dev-ruby/rack:2.0
+ >=dev-ruby/rack-test-0.6.3:0.6
+ >=dev-ruby/rails-html-sanitizer-1.0.2:1
+ dev-ruby/rails-dom-testing:2
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ >=dev-ruby/capybara-2.13:2
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ www-servers/puma
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+ sed -i -e '1igem "rack-test", "~>0.6.3"; gem "activemodel", "~>5.1.0"; gem "railties", "~>5.1.0"' test/abstract_unit.rb || die
+}