summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-02 13:22:15 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-02 13:22:52 +0200
commit1dd5365e3ebe849457456a6541d0268bdca954f1 (patch)
tree748c5b0f534498a64adf90b864a5e474b0b07546 /dev-ruby/actiontext
parentdev-ruby/activerecord: add 6.0.6 (diff)
downloadgentoo-1dd5365e3ebe849457456a6541d0268bdca954f1.tar.gz
gentoo-1dd5365e3ebe849457456a6541d0268bdca954f1.tar.bz2
gentoo-1dd5365e3ebe849457456a6541d0268bdca954f1.zip
dev-ruby/actiontext: add 6.0.6
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index fc6d55ad1cf6..0681ef42bebd 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -1,4 +1,5 @@
DIST rails-6.0.5.1.tgz 18607954 BLAKE2B 74f75399a287f1eae199a5764c952b75dd95a02c88899ade69d60acae00a7588b2f3a8ab3b9d2c9224d62f87305c596e16b196a5c32b19731d4415f17a29d38e SHA512 a65c3fab39eadba75e0107486c82a4da212e612ddb2350f77bb00ad887e0b52980edba08d42c02801c4e4fd71d750de3dbd78c820ef050016867737dccc06b36
+DIST rails-6.0.6.tgz 18611499 BLAKE2B 156ab379f1fed2380544127096490cfdab1264dc352db08e0b48c4cf3cde9a564f618c86650203c018597b6425d03f550103778f5255e5026e8d50e9a8adf5c9 SHA512 5754f3dda4f279daec397358b692bb53c191c335218a365eb7ea6d374af32c35bd3e5268dd2d71a7481855020b43726b77f0ce440cbcc73130df8b72565234c7
DIST rails-6.1.6.1.tgz 11028264 BLAKE2B 568033eb816613ba0ba5f2df38e6a30158b2e31ef4d4da151f8c0de2934b07736833026793ce9192994d9ef2a2a45b67735a35760c1be8b8a68c1968147cc6db SHA512 04acf9dbf5ee734636aada67be001690899eb13f73ea688455fcaee8cbf4839aedf06943c8adb5eecf13fd9a5f6be1a225310aa481d3a254172fd0ce0402362f
DIST rails-6.1.7.tgz 11038670 BLAKE2B fd25884a6f58f10387f1f89ffd39caad337d7a3af6902f9ccdcf4eb108f9355124b6e1004d8b8f2b625ac7d9cfcd8635e7668101a1cba5d866a5fbe1b691e6e2 SHA512 7d56f604fbc2fb83a2e3a4ee070f55fb285018a48584115e0bf19982553eb5b78a173a5adbf1879e88c0739bea9dccc66879646da5c0b141b24f1500e1bdcb5f
DIST rails-7.0.3.1.tgz 11049683 BLAKE2B 31aa9c20b4add7e11b832aff57fcf78284b7f28e71cfc71b5769c65170f1fff3f33d73224bbfa826852a59aac30671ff7c3ef19cbe0aaabc8528a805c6b98e8a SHA512 2ad615df9e019193489d5ce82152fd0ff12d8435401258b2b8a87d1c5da46587cdd45dc483847891f7b8be1d019b09b77a48fa7849d5260ee6fdbbf6df64ef03
diff --git a/dev-ruby/actiontext/actiontext-6.0.6.ebuild b/dev-ruby/actiontext/actiontext-6.0.6.ebuild
new file mode 100644
index 000000000000..d56f4d15147d
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.0.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|sass-rails\|webpacker\|rubocop\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|byebug\|dalli\)/ s:^:#:" \
+ -e '/minitest/ s/5.15/5.16/' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}