summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-16 06:41:32 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-16 06:42:05 +0100
commit631b7860ce95d2b58ac8683293f51be10ab86d76 (patch)
tree6dc8d7444eb0cadb80f72c8cad6379fe1aab2d29 /dev-ruby/actiontext
parentdev-ruby/activerecord: add 6.1.4.4 (diff)
downloadgentoo-631b7860ce95d2b58ac8683293f51be10ab86d76.tar.gz
gentoo-631b7860ce95d2b58ac8683293f51be10ab86d76.tar.bz2
gentoo-631b7860ce95d2b58ac8683293f51be10ab86d76.zip
dev-ruby/actiontext: add 6.1.4.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-6.1.4.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 564fa98ca0f7..7806cbd4abf7 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -3,3 +3,4 @@ DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbd
DIST rails-6.0.4.4.tgz 18594292 BLAKE2B 8f463900db30ffd4850b270aac0ae8c160af36a606e4eddaadbd2a0c086de3438a36665586e20a4b6b8873f8b659f2ecd3e32965a36118a6e63fad2726afa0f5 SHA512 14f7d51ba407589eb4ef1db8a99c21c301198e8cb2fcdf611c76eebd1d52192eb1225bb5d45a2183fbfe103a0b987f3a95c6c5fe6d772ba101da9ed46441441f
DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
DIST rails-6.1.4.3.tgz 11007190 BLAKE2B 085d500407f03d8c46335d91e3ebc5cd092c801de25f7e4fd5ac4ae6f03e54c5347e720386763307e183e2f0f48aaf84142092f47b62ab395082e4068e46f883 SHA512 f47a2e155fc80c287360b1a17a0f870208c523a28b77737648b4f260dc4fec6e9ccc91861b84862828fda48c214d39dcff32430ed5a02c8b9ee59ba6efb6151c
+DIST rails-6.1.4.4.tgz 11006695 BLAKE2B af5afbd1adafa259f3d58d31e8e616be5e83e73d3e7231fd62717c0a8c0012e7ecf5346f2465a61f72d96fdc71755e954069adfebc84dddddcb29cb8a215cee1 SHA512 4215be8f447e5b486a1c0d99208fbeb1f7222aa3bdff7127e31c95670a74aa315a044df0048a55fd078f42a07f17d4b7248efc09d6fac2a4b6efef8624a509ef
diff --git a/dev-ruby/actiontext/actiontext-6.1.4.4.ebuild b/dev-ruby/actiontext/actiontext-6.1.4.4.ebuild
new file mode 100644
index 000000000000..2f8569204837
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.1.4.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}