summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-15 06:57:01 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-15 06:57:36 +0100
commitddfa1cb0cd1f3e0e1792c8a0d0b24b5914dd1517 (patch)
tree0c261b8f366097c43b4d3540dba0a067bef6f007 /dev-ruby/actiontext
parentdev-ruby/activerecord: add 6.0.4.3 (diff)
downloadgentoo-ddfa1cb0cd1f3e0e1792c8a0d0b24b5914dd1517.tar.gz
gentoo-ddfa1cb0cd1f3e0e1792c8a0d0b24b5914dd1517.tar.bz2
gentoo-ddfa1cb0cd1f3e0e1792c8a0d0b24b5914dd1517.zip
dev-ruby/actiontext: add 6.0.4.3
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.4.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index 9caf787181b1..44f32ff2ecd7 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -1,2 +1,3 @@
DIST rails-6.0.4.1.tgz 18595307 BLAKE2B 9a950a45cd04c5fe0cbe57fd014a6997074dcbe8f95fcbb2f5d3b6372867ef8bb0931b909ca8eba623787419f5f45504cdcd477729ba3b3a052f5003229121cd SHA512 322cfa6d0ed62f0660ce2f43003b2a745297f3b82dca486d7e4a9821441ad4ec92c202556515645d141fba31c998e17aa00bbe3d8c2106718e6839f94e88c975
+DIST rails-6.0.4.3.tgz 18594602 BLAKE2B 99ee38f02ffece7972b34dc4bf8de6aece131fbdd1ac92c01272296e87b033d0a877a4fc724d3acece0442025ff9906a3e735ae75a8313135f2ffc55be988b38 SHA512 ae71145cc6e2a532271f6fe063347b261a7c6b1153f4978da5fd539b51b356baa555e731b759d9b49c342b2623b30ff9962396346df66d7e97aeca1fa806b333
DIST rails-6.1.4.1.tgz 11003728 BLAKE2B 8baa45968536ebe34f3bc4e4f25246bff68997a88c1019d1f7b7ba73785bc11901d7222ac04866b900c7dc35f9291ede78c0949abd979e797d07f3759179c05a SHA512 411d3fe21c7500e884edb86cc6728c4d3b7125d2e6ea913191437716f2be0d522252c55c25cb4c5221cc112b3ca5eeba690b0b0e59572fcc54ea42ba05ec4520
diff --git a/dev-ruby/actiontext/actiontext-6.0.4.3.ebuild b/dev-ruby/actiontext/actiontext-6.0.4.3.ebuild
new file mode 100644
index 000000000000..6578fa8e6b1a
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.0.4.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|sass-rails\|webpacker\|rubocop\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|bootsnap\|capybara\|byebug\|dalli\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}