summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/activejob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/activejob')
-rw-r--r--dev-ruby/activejob/Manifest2
-rw-r--r--dev-ruby/activejob/activejob-4.2.2.ebuild44
-rw-r--r--dev-ruby/activejob/activejob-4.2.3.ebuild44
-rw-r--r--dev-ruby/activejob/metadata.xml8
4 files changed, 98 insertions, 0 deletions
diff --git a/dev-ruby/activejob/Manifest b/dev-ruby/activejob/Manifest
new file mode 100644
index 000000000000..8505116441fd
--- /dev/null
+++ b/dev-ruby/activejob/Manifest
@@ -0,0 +1,2 @@
+DIST rails-4.2.2.tgz 4149494 SHA256 e8a0b1f96e2bf0bf24b2f28a5b5eabed7886b056119bd51c01ed451db4f35932 SHA512 707fddfcabf960ebccac9aa8c88067b1adedee341eed80a60c07044145f67047a91eb6d52b05c18d0693f0e575ec51b494b3095df755067f7cacd3a62275189f WHIRLPOOL 6b9296edbcaf95c20adf2981f877cf0b6febc4e2f33873826ab36ff0cdff68308c8e748bd9fdfb56f1d4e72c1588e25b826103ab7df9d74dd0e4e756d61d648a
+DIST rails-4.2.3.tgz 4160455 SHA256 79956b73a496d4e409d7bc639980049ba58e1a2976c6cd3beaffc596e913f337 SHA512 6e6cd821764b7b9f86cefc5a075ec590711d9f465a2692a6ee4b403ced8ff262bf5723da2b7061b7b9a450f3af1c99f781f1230844ede201f5ad828c34d9c9ea WHIRLPOOL 351a2cd4571ae0ad0e39304267f0bcfd5fd544bc38bec75beaed50ebe802d0215660e31edf9ac00cb5acb6ad1c0b32947fa7b161d8ecbc490006ecc51f94fd4c
diff --git a/dev-ruby/activejob/activejob-4.2.2.ebuild b/dev-ruby/activejob/activejob-4.2.2.ebuild
new file mode 100644
index 000000000000..6622bbe62f0f
--- /dev/null
+++ b/dev-ruby/activejob/activejob-4.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.0
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/delayed_job qu que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
+}
diff --git a/dev-ruby/activejob/activejob-4.2.3.ebuild b/dev-ruby/activejob/activejob-4.2.3.ebuild
new file mode 100644
index 000000000000..6622bbe62f0f
--- /dev/null
+++ b/dev-ruby/activejob/activejob-4.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.0
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/delayed_job qu que queue_classic resque sidekiq sneakers sucker_punch backburner//' Rakefile || die
+}
diff --git a/dev-ruby/activejob/metadata.xml b/dev-ruby/activejob/metadata.xml
new file mode 100644
index 000000000000..73034e5a17a2
--- /dev/null
+++ b/dev-ruby/activejob/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">rails/rails</remote-id>
+ </upstream>
+</pkgmetadata>