summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-09 05:55:58 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-09 05:55:58 +0200
commiteccfac0b6f958ee375917c4de25f02f903d4aa9d (patch)
treedad0ee5adfcfae14ac2183a8fe8aa9715e9a64be /dev-ruby/activeldap/activeldap-5.2.0.ebuild
parentdev-db/mariadb-galera: Fix package moved xtrabackup-bin dep (diff)
downloadgentoo-eccfac0b6f958ee375917c4de25f02f903d4aa9d.tar.gz
gentoo-eccfac0b6f958ee375917c4de25f02f903d4aa9d.tar.bz2
gentoo-eccfac0b6f958ee375917c4de25f02f903d4aa9d.zip
dev-ruby/activeldap: add 5.2.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/activeldap/activeldap-5.2.0.ebuild')
-rw-r--r--dev-ruby/activeldap/activeldap-5.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/activeldap-5.2.0.ebuild b/dev-ruby/activeldap/activeldap-5.2.0.ebuild
new file mode 100644
index 000000000000..be5311720e6c
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-5.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >dev-ruby/activemodel-4.0.0:*
+ dev-ruby/builder
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( dev-ruby/ruby-net-ldap >=dev-ruby/ruby-ldap-0.8.2 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}