summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-08 08:17:08 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-08 08:17:08 +0200
commit4160453451d7d980ebdfe97a71627d8755febeb1 (patch)
tree63ed0316adfd13385fb9af954ba7c435e6475e7e /dev-ruby/activerecord
parentdev-ruby/actionmailer: add 5.2.1 (diff)
downloadgentoo-4160453451d7d980ebdfe97a71627d8755febeb1.tar.gz
gentoo-4160453451d7d980ebdfe97a71627d8755febeb1.tar.bz2
gentoo-4160453451d7d980ebdfe97a71627d8755febeb1.zip
dev-ruby/activerecord: add 5.2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/Manifest1
-rw-r--r--dev-ruby/activerecord/activerecord-5.2.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-ruby/activerecord/Manifest b/dev-ruby/activerecord/Manifest
index 9e79345d7283..624813174273 100644
--- a/dev-ruby/activerecord/Manifest
+++ b/dev-ruby/activerecord/Manifest
@@ -4,3 +4,4 @@ DIST rails-5.1.4.tgz 6132874 BLAKE2B ec5642b860b7c18cea2c56aa5e2a652e28ab08d39c5
DIST rails-5.1.5.tgz 6142269 BLAKE2B e31b6fb39df4a5cbfa9acd31058b018f5eb8d45d0886d9cb1de5d7de9ed082b67f27d257ac8eeffb0a2663466bc958c72d63309f0a68989d189a11510e835e3e SHA512 8fde1b043976c6bd69235ccbfc1f4ab593fa0cb7ec0dc0cbafcbd2727dfd1b405cc6131e41cc40871bc893cc64f524a347dd91efd1816b724deb5ca1cf879c63
DIST rails-5.1.6.tgz 6142931 BLAKE2B 0c24677946c3421e73903214822a13cb26609a3c7e7826020b76a48809a8672c1dfb05d1bd362fab956a397636db5e691a91bdea64ee6073190e8663fb58a7df SHA512 1ad70fb57af753bb6aff27345021af97d177aed95e295273044d8ef5723aa6b64fc03104d2cbd1cc5337127f71b3eef9b19fa582f4d53cb746ed9b152a8392bb
DIST rails-5.2.0.tgz 9233349 BLAKE2B 8b237f7b039baed6d2a3f19d138f5985443d8543247b01ba316668052fede66820894e3f5ef76a953a4bdb54febecb6299692899556ea029ebfcbcebbaba9409 SHA512 0d7fdbc05a69f7a7b5ce612c0ec8e5dcd51ffb63891d97ca08036d07b3fb3267699dd4a209fd698e5eb2ca8f6c7f4539e86044c3bd15d0c614feda16892d3d85
+DIST rails-5.2.1.tgz 8795554 BLAKE2B 712fba696aeb8600dcd3b031b84a7ec164aa4d8ec386576ff367d5d45b3effd48515c9b8ef36ea93642776220685a1d8eec6909f705e62a80a06cf151fc42b43 SHA512 4484981845f9bba8882db6b4d1e0c4600b54baeda5cf1825fda7cbbb04cfdcf35e4caa19355cb843d1b96fc67801f28902d79d763dae71446db515691a32742e
diff --git a/dev-ruby/activerecord/activerecord-5.2.1.ebuild b/dev-ruby/activerecord/activerecord-5.2.1.ebuild
new file mode 100644
index 000000000000..2f581e941789
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-5.2.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="mysql postgres sqlite"
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ dev-ruby/arel:9.0
+ sqlite? ( >=dev-ruby/sqlite3-1.3.6 )
+ mysql? ( || ( dev-ruby/mysql2:0.4 >=dev-ruby/mysql2-0.3.18:0.3 ) )
+ postgres? ( >=dev-ruby/pg-0.18.0:* )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ >=dev-ruby/sqlite3-1.3.6
+ dev-ruby/mocha
+ dev-ruby/minitest:5
+ )"
+
+DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ rm ../Gemfile.lock || die
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+ sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
+
+ # Add back json in the Gemfile because we dropped some dependencies
+ # earlier that implicitly required it.
+ sed -i -e '$agem "json"' ../Gemfile || die
+
+ # Avoid test depending on mysql adapter which we don't support for
+ # this Rails version to simplify our dependencies.
+ rm test/cases/connection_specification/resolver_test.rb || die
+
+ # Avoid single test using mysql dependencies.
+ rm test/cases/invalid_connection_test.rb || die
+
+ # Avoid failing test that makes bad assumptions on database state.
+ sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
+ test/cases/associations/has_many_associations_test.rb
+}
+
+each_ruby_test() {
+ if use sqlite; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+}