summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-25 07:55:09 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-25 07:56:28 +0100
commit5e5bd950285ab065c146b3a8b0e83e0c87a9d372 (patch)
treee1c8a2486ade143e1dbd90d413e99f644317deac /dev-ruby/activerecord
parentdev-ruby/actionview: drop 6.1.7.4 (diff)
downloadgentoo-5e5bd950285ab065c146b3a8b0e83e0c87a9d372.tar.gz
gentoo-5e5bd950285ab065c146b3a8b0e83e0c87a9d372.tar.bz2
gentoo-5e5bd950285ab065c146b3a8b0e83e0c87a9d372.zip
dev-ruby/activerecord: drop 6.1.7.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/Manifest1
-rw-r--r--dev-ruby/activerecord/activerecord-6.1.7.4.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-ruby/activerecord/Manifest b/dev-ruby/activerecord/Manifest
index a6f5a961de4c..33378090f247 100644
--- a/dev-ruby/activerecord/Manifest
+++ b/dev-ruby/activerecord/Manifest
@@ -1,4 +1,3 @@
-DIST rails-6.1.7.4.tgz 11038583 BLAKE2B 737044b6f92f2555fd9374e0b0fef7e26e53e2ac2103f1e3d89124929416aeda1295adfa7493471472c6ff0fbb057dea0bd9c184bbb45ae572185b98c399177f SHA512 caa7e2a79f747befb5f6f17adec1cc43530dbb35741775b2ebdcf59476efecd277dad025073a4b519a35754367cca04290c24bb8d8ae4235fda696ead531a94f
DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f512e86df66b3e921375ffa3ea11e15f1d74a7f8ec9179ff70c32a6d4f8de75be5f92fe6315ee97164e22d2d0 SHA512 c4163565b2324ce97317d252f3d9e2e673a12b6ae7f54571645c958ce30221f1b357887ade80e46abdd47a422736b9946e49850d52ffd72d8acc87f35224e69f
DIST rails-6.1.7.7.tgz 11041447 BLAKE2B 3f59325aa86d3b7d6e0773b9eb2b895a26b644109be8df0b0d9abbab8e6c77f76d316c717ecce4e2d79d3247559504a7452a8037d2d52a6cf95fbacd7f8b8612 SHA512 f9af4eebb3bffec78832f92be6158c71c147e265b54e8e368a06c762bfd1a7992256b3e9286aeb59eee69ba56be28d381a715eb13f99b9babfd9b7ce8051e210
DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
diff --git a/dev-ruby/activerecord/activerecord-6.1.7.4.ebuild b/dev-ruby/activerecord/activerecord-6.1.7.4.ebuild
deleted file mode 100644
index 8ff5365b8c24..000000000000
--- a/dev-ruby/activerecord/activerecord-6.1.7.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="https://github.com/rails/rails/"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="mysql postgres sqlite"
-
-RUBY_S="rails-${PV}/${PN}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ruby32-keywords.patch
-)
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- sqlite? ( >=dev-ruby/sqlite3-1.4 )
- mysql? ( dev-ruby/mysql2:0.5 )
- postgres? ( >=dev-ruby/pg-1.1:1 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/railties-${PV}
- >=dev-ruby/sqlite3-1.4.0
- dev-ruby/mocha
- <dev-ruby/minitest-5.16:*
- )"
-
-DEPEND+=" test? ( >=dev-db/sqlite-3.12.1 )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- rm ../Gemfile.lock || die
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -e '/bcrypt/ s/3.0.0/3.0/' \
- -i ../Gemfile || die
- sed -i -e '/byebug/ s:^:#:' test/cases/base_prevent_writes_test.rb || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Load correct rails version
- sed -i -e '2igem "activemodel", "~> 6.1.0"; gem "activejob", "~> 6.1.0"; gem "railties", "~> 6.1.0"; gem "minitest", "<5.16"' test/cases/helper.rb || die
-
- # Avoid single tests using mysql or postgres dependencies.
- rm test/cases/invalid_connection_test.rb || die
- sed -e '/test_switching_connections_with_database_url/askip "postgres"' \
- -i test/cases/connection_adapters/{,legacy_}connection_handlers_multi_db_test.rb || die
-
- # Avoid failing test that makes bad assumptions on database state.
- sed -i -e '/test_do_not_call_callbacks_for_delete_all/,/^ end/ s:^:#:' \
- test/cases/associations/has_many_associations_test.rb
-
- # Avoid tests that no longer work with newer sqlite versions
- rm -f test/cases/adapters/sqlite3/explain_test.rb || die
- sed -i -e '/test_references_stays_as_integer_column/askip "Fails on case difference"' test/cases/migration/compatibility_test.rb || die
-
- # Avoid test failing to bind limit length in favor of security release
- sed -i -e '/test_too_many_binds/askip "Fails on Gentoo"' test/cases/bind_parameter_test.rb || die
-
- # Avoid test failing related to rubygems
- sed -i -e '/test_generates_absolute_path_with_given_root/askip "rubygems actiovation monitor"' test/cases/tasks/sqlite_rake_test.rb || die
-}
-
-each_ruby_test() {
- if use sqlite; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
-}