summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-11-29 08:24:50 +0100
committerHans de Graaff <graaff@gentoo.org>2018-11-29 08:30:44 +0100
commitf70206ff0b5ab9b4b05435505507dadc1ded697f (patch)
treecc7f9fec97c65e65e808be047b7503c78b0d4cdf /dev-ruby/activestorage
parentdev-ruby/actionpack: add 5.2.1.1 (diff)
downloadgentoo-f70206ff0b5ab9b4b05435505507dadc1ded697f.tar.gz
gentoo-f70206ff0b5ab9b4b05435505507dadc1ded697f.tar.bz2
gentoo-f70206ff0b5ab9b4b05435505507dadc1ded697f.zip
dev-ruby/activestorage: add 5.2.1.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/activestorage')
-rw-r--r--dev-ruby/activestorage/Manifest1
-rw-r--r--dev-ruby/activestorage/activestorage-5.2.1.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/activestorage/Manifest b/dev-ruby/activestorage/Manifest
index 8a992be55263..4fe609f469bd 100644
--- a/dev-ruby/activestorage/Manifest
+++ b/dev-ruby/activestorage/Manifest
@@ -1,2 +1,3 @@
DIST rails-5.2.0.tgz 9233349 BLAKE2B 8b237f7b039baed6d2a3f19d138f5985443d8543247b01ba316668052fede66820894e3f5ef76a953a4bdb54febecb6299692899556ea029ebfcbcebbaba9409 SHA512 0d7fdbc05a69f7a7b5ce612c0ec8e5dcd51ffb63891d97ca08036d07b3fb3267699dd4a209fd698e5eb2ca8f6c7f4539e86044c3bd15d0c614feda16892d3d85
+DIST rails-5.2.1.1.tgz 8795521 BLAKE2B 93b30ba7b9127d2fc4dae6c7e7884f0a4ab36805b440c37ca8e2b81a5ba2b9ccaa4d30e65599cfb036befc4ec58942d3eba71ba9683becb535e8a822d3a8422e SHA512 bd2c13f06d524a03547341acee3422a58a306a1c33a896073648e4ddcac296a8e397bd73fd5928dae1e66ba3b4a42ac4ea5f0a7cca1f73b2e773b8ece24a76d0
DIST rails-5.2.1.tgz 8795554 BLAKE2B 712fba696aeb8600dcd3b031b84a7ec164aa4d8ec386576ff367d5d45b3effd48515c9b8ef36ea93642776220685a1d8eec6909f705e62a80a06cf151fc42b43 SHA512 4484981845f9bba8882db6b4d1e0c4600b54baeda5cf1825fda7cbbb04cfdcf35e4caa19355cb843d1b96fc67801f28902d79d763dae71446db515691a32742e
diff --git a/dev-ruby/activestorage/activestorage-5.2.1.1.ebuild b/dev-ruby/activestorage/activestorage-5.2.1.1.ebuild
new file mode 100644
index 000000000000..73eab3a2fa78
--- /dev/null
+++ b/dev-ruby/activestorage/activestorage-5.2.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Attach cloud and local files in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+DEPEND+=" test? ( app-text/mupdf ) "
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ ~dev-ruby/activerecord-${PV}:*
+ >=dev-ruby/marcel-0.3.1 =dev-ruby/marcel-0.3*
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ dev-ruby/test-unit:2
+ dev-ruby/mini_magick
+ dev-ruby/mocha
+ dev-ruby/rake
+ dev-ruby/sqlite3
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\|capybara\|rack-cache\|json\|dalli\|listen\|connection_pool\|puma\|mysql2\)/ s:^:#:" \
+ -e '/dalli/ s/2.7.7/2.7.9/' \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/:test/,/^end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
+ rm ../Gemfile.lock || die
+}