summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-07 12:09:28 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-07 12:11:30 +0200
commit37250e004b7be7bf034f72f7a96d4ab13d39fb5a (patch)
tree9ae2e24a133d28f036a640f90fe5ff60c6c217b9 /dev-ruby/activesupport
parentdev-python/greenlet: Bump to 3.0.0 (diff)
downloadgentoo-37250e004b7be7bf034f72f7a96d4ab13d39fb5a.tar.gz
gentoo-37250e004b7be7bf034f72f7a96d4ab13d39fb5a.tar.bz2
gentoo-37250e004b7be7bf034f72f7a96d4ab13d39fb5a.zip
dev-ruby/activesupport: add 7.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.1.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 655ecd754075..f0aadf928c7f 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -3,3 +3,4 @@ DIST rails-6.1.7.6.tgz 11040086 BLAKE2B 8b5311752952403cf8eae31b5d8e8d376c4b449f
DIST rails-7.0.7.2.tgz 11085454 BLAKE2B 05574b6df7e28e409949fb311110fd7137d61c31072b394f950a180135201132f3cf9c5cca8f76c661827d7a5e807bfc4b0c97a449b8941115cbe3a0f2f84f62 SHA512 41fad11bd272ea21f7d15d855da04230f0801d9926f6ce3300754f1b2b9d691f18e55855b1a71e44faaf483b397b02ac11c75eb415b7c8976868bc9aefe5b005
DIST rails-7.0.7.tgz 11071730 BLAKE2B 215642609be86bd9977dc2cdb09a76c64e99260359d0a60aa411a5df572d7699a5f9959ea8aa0ff116ad75110db060436abcfb17da689b1a6aa819fd56373279 SHA512 75f952dfe4d9abc1473dfb017e42daec6358a45efad14a3b39a1b2dc5fec566757c2225fe920a4e872e896966cfb1d4b6e1c40c93d2043aec3bf5bd25ff7c956
DIST rails-7.0.8.tgz 11073254 BLAKE2B 2aee047a365acb0890ef3afbccfe323fedccf7b54214aa1c2f92b7a7aaa64c275c1e03f8f97e6a2e30281224ba30703d18b40aeee9b4e7fb6f035a4a7716a054 SHA512 0e9feb5bd0360868c3109152d8ea414b65d36d33a5dbb96b199cfa6c4335800d6c392e0fbcbfa453a02fd75924a297a65caf04948895de53db43700478dbeb11
+DIST rails-7.1.0.tgz 10869663 BLAKE2B b6bda46d861da68caba103ca161be93fd600fe218f797eae0294ee2280e82164469a1573b12dac8c01b7c640bec9f05e308ed2e47c9f9dd79ac42b05ee0c563a SHA512 99bb1255a62e4ebbb800780b12e2b0bce94bd4ac1639f03adb2fbcd06535f9f6965b4ebb3f289874fccb8d5c73ed83c285b04f100d1bda6d7e9c9759d41c893e
diff --git a/dev-ruby/activesupport/activesupport-7.1.0.ebuild b/dev-ruby/activesupport/activesupport-7.1.0.ebuild
new file mode 100644
index 000000000000..a60c561e4a43
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# bigdecimal and mutex_m are bundled with ruby as default gems
+ruby_add_rdepend "
+ dev-ruby/base64
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/connection_pool-2.2.5
+ dev-ruby/drb
+ >=dev-ruby/i18n-1.6:1
+ >=dev-ruby/minitest-5.1
+ dev-ruby/tzinfo:2
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack:3.0
+ dev-ruby/rexml
+ dev-ruby/mocha
+ >dev-ruby/minitest-5.15.0:*
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|execjs\|jquery-rails\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\|rack-test\|terser\|cgi\|net-smtp\|net-imap\|net-pop\|digest\|matrix\|web-console\|error_highlight\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/^group :test/,/^end/ s:^:#:' \
+ -e '/^\s*group :\(db\|doc\|rubocop\|job\|cable\|lint\|storage\|ujs\|test\|view\) do/,/^\s*end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}