summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-01 08:29:16 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-01 08:39:46 +0200
commit55128bd4de91d0ffea04569b3b8da7f651d04a69 (patch)
treec87742dd0da232124e4e6309ef6e950e344b49a5 /dev-ruby/activesupport
parentdev-ruby/nokogiri: cleanup (diff)
downloadgentoo-55128bd4de91d0ffea04569b3b8da7f651d04a69.tar.gz
gentoo-55128bd4de91d0ffea04569b3b8da7f651d04a69.tar.bz2
gentoo-55128bd4de91d0ffea04569b3b8da7f651d04a69.zip
dev-ruby/rails: add rails 5.1.6
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-5.1.6.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 21e4fb17b6a0..11179856034b 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -4,3 +4,4 @@ DIST rails-5.0.7.tgz 6051560 BLAKE2B d5090b2e6c3fb9b7ca460c7439a94d6633ab7bad3ce
DIST rails-5.1.1.tgz 6124695 BLAKE2B 6a02843a036594d02aee37413713950f495db24651df49be3866e2df989d464a23ac5865081d243e6c6525837fb33099c46b6009cc667d0e03444cbcf9631588 SHA512 fd62506eac440f1ad9b37f20c7c712733440bc2ee676390c02e3bd50b912fe0fd53e8092c23664d47818ee62583568c6e20d2bfd5eff6d22a005289bb3bb258f
DIST rails-5.1.4.tgz 6132874 BLAKE2B ec5642b860b7c18cea2c56aa5e2a652e28ab08d39c5863dc4ee66fd3caf375e55706e4317ecae5bfc5581922cf1549c38c22529d2e44a98c84cde332491e49cc SHA512 8f0837e0a2c5b0189375f10310a6e6b43e32f1fecc503582efc6490436c943e774495262e508e4ca1a1874132ae6e4a541e81c06f0d8f6fe8ab85bd2fd10d4fc
DIST rails-5.1.5.tgz 6142269 BLAKE2B e31b6fb39df4a5cbfa9acd31058b018f5eb8d45d0886d9cb1de5d7de9ed082b67f27d257ac8eeffb0a2663466bc958c72d63309f0a68989d189a11510e835e3e SHA512 8fde1b043976c6bd69235ccbfc1f4ab593fa0cb7ec0dc0cbafcbd2727dfd1b405cc6131e41cc40871bc893cc64f524a347dd91efd1816b724deb5ca1cf879c63
+DIST rails-5.1.6.tgz 6142931 BLAKE2B 0c24677946c3421e73903214822a13cb26609a3c7e7826020b76a48809a8672c1dfb05d1bd362fab956a397636db5e691a91bdea64ee6073190e8663fb58a7df SHA512 1ad70fb57af753bb6aff27345021af97d177aed95e295273044d8ef5723aa6b64fc03104d2cbd1cc5337127f71b3eef9b19fa582f4d53cb746ed9b152a8392bb
diff --git a/dev-ruby/activesupport/activesupport-5.1.6.ebuild b/dev-ruby/activesupport/activesupport-5.1.6.ebuild
new file mode 100644
index 000000000000..61edd3151418
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-5.1.6.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-0.7:* =dev-ruby/i18n-0*:*
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.0.5:3
+ dev-ruby/rack
+ dev-ruby/mocha:0.14
+ <dev-ruby/minitest-5.4
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :doc/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/caching_test.rb || die
+}