summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-01-27 10:44:19 +0100
committerHans de Graaff <graaff@gentoo.org>2023-01-27 10:46:25 +0100
commit9fdbc6af0543b117a8e879f7560e119f9a87568f (patch)
tree73f04299a8aa650f03b4cc211ee655d7dce056e0 /dev-ruby/activesupport
parentsec-keys/openpgp-keys-valgrind: Stabilize 20230124 ppc64, #892195 (diff)
downloadgentoo-9fdbc6af0543b117a8e879f7560e119f9a87568f.tar.gz
gentoo-9fdbc6af0543b117a8e879f7560e119f9a87568f.tar.bz2
gentoo-9fdbc6af0543b117a8e879f7560e119f9a87568f.zip
dev-ruby/activesupport: add 7.0.4.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.0.4.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 2aa0c24e20b2..ab2b8bcd4b78 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -7,4 +7,5 @@ DIST rails-6.1.7.1.tgz 11035161 BLAKE2B 16e5c6e323403c117443b10ef151ba94cf27cd6f
DIST rails-6.1.7.tgz 11038670 BLAKE2B fd25884a6f58f10387f1f89ffd39caad337d7a3af6902f9ccdcf4eb108f9355124b6e1004d8b8f2b625ac7d9cfcd8635e7668101a1cba5d866a5fbe1b691e6e2 SHA512 7d56f604fbc2fb83a2e3a4ee070f55fb285018a48584115e0bf19982553eb5b78a173a5adbf1879e88c0739bea9dccc66879646da5c0b141b24f1500e1bdcb5f
DIST rails-7.0.3.1.tgz 11049683 BLAKE2B 31aa9c20b4add7e11b832aff57fcf78284b7f28e71cfc71b5769c65170f1fff3f33d73224bbfa826852a59aac30671ff7c3ef19cbe0aaabc8528a805c6b98e8a SHA512 2ad615df9e019193489d5ce82152fd0ff12d8435401258b2b8a87d1c5da46587cdd45dc483847891f7b8be1d019b09b77a48fa7849d5260ee6fdbbf6df64ef03
DIST rails-7.0.4.1.tgz 11063201 BLAKE2B 9efdb43546d73cbff42297ac988604318e298fb06954cfc066861c63e6336797dca85e7ef40f1e3255fd9fab8fbc111ad1265023a6ced0a25fd1d1a416cb8da5 SHA512 551317bf1d837836eabf4f0de6be1f83916c57b5f828ce079288c37665bac636dd95c076a965d6d763c69f425aef3b5cc20d1fcfdd22eb638cf7175c891466a2
+DIST rails-7.0.4.2.tgz 11063555 BLAKE2B f8a862ce91a356dad702a44f1e36f8910e91481770118343c13fa00e40d57cd208ebea83e5adc0154927ef62b3f8461ded82c4e5097089fb1d872c2247feba44 SHA512 9fb80e9ec6e9edcf049635eb436c2fdb418cbdea47a6d82fefa7606e9bd14f2785b1c4445f08848692474db7ee3eb309ab26aabc5f3ba6847457d8dfd8802689
DIST rails-7.0.4.tgz 11061225 BLAKE2B 9c520766f936c82ae9ee943c3db0ad575d7fc59aea947fb2790cf511188fbd33166a62332564c4714372203f5fabdde842334103b48f4115c31f5d0fe18375f1 SHA512 118035226054ad5083d2affde55a812917652491f82a9a578380a790770fdda3a14904f6de10f58651bbbab278aa23920b652aa1b34c71441d465c3b7b4be82c
diff --git a/dev-ruby/activesupport/activesupport-7.0.4.2.ebuild b/dev-ruby/activesupport/activesupport-7.0.4.2.ebuild
new file mode 100644
index 000000000000..f0801876283b
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.0.4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ <dev-ruby/minitest-5.16:5
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\|rack-test\|terser\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\|view\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}