summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-13 07:25:21 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-13 07:27:20 +0200
commitff7fe31bed52ba2f80d54082a04667f232ba382d (patch)
treee6180581ec78c9bb4c53ab98a4f96ebc8e5a7024 /dev-ruby/activesupport
parentapp-emulation/libguestfs-appliance: fix guestfs-tools comment (diff)
downloadgentoo-ff7fe31bed52ba2f80d54082a04667f232ba382d.tar.gz
gentoo-ff7fe31bed52ba2f80d54082a04667f232ba382d.tar.bz2
gentoo-ff7fe31bed52ba2f80d54082a04667f232ba382d.zip
dev-ruby/activesupport: add 6.1.6.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-6.1.6.1.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index d53387437f74..43be688ef327 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -1,6 +1,7 @@
DIST rails-5.2.8.tgz 8847449 BLAKE2B 11937ee2aeea39cade43829a01430315a997fef070fc73a1e63baaff8b3631f82561c7acdd44cf1981501424be68d814001dd26cbf7678ca987a8311d109d367 SHA512 98e1b36bdd4235e983d0805b6ff9779e3793d1bed486dc6de854215c4294334d5036157a527c1222cc2be4c107754553dadf2bf86e65ce6561dd8152c47ef84a
DIST rails-6.0.5.tgz 18572922 BLAKE2B cc7f3669f5d501031ea5bfcef24db89040dc447923abe255b4ae504c07c648414a19a5d2c7ecb513cb96cf601440caeb2462c37fdae61770cef60ce5708abcb4 SHA512 5f262f65de2e3057b92fdb95bef28ea8c4c44e5ca27f4065bb4946a760b3f97fde10f9a303ccf1fdbf833f1e26db5cde722183f41672614203c4b08aef6780ed
DIST rails-6.1.5.1.tgz 10993257 BLAKE2B 90146d33fcad068a09bc61c09417514f2ccc18c51043c63672397eb6980a97c9c0c4e6b0679393c3d8ded690ab44ea53b7abd49817f46ca9f8ab3472dec2f3c3 SHA512 8061f2103ad9266f06f902cf7f05b3f94b05d9b454d314d7a7febea2e5e464c5f33d14f48a2a098e7e666a6dc8cd5c5dae4cf4fb669eca28303a4fb5e6832039
+DIST rails-6.1.6.1.tgz 11028264 BLAKE2B 568033eb816613ba0ba5f2df38e6a30158b2e31ef4d4da151f8c0de2934b07736833026793ce9192994d9ef2a2a45b67735a35760c1be8b8a68c1968147cc6db SHA512 04acf9dbf5ee734636aada67be001690899eb13f73ea688455fcaee8cbf4839aedf06943c8adb5eecf13fd9a5f6be1a225310aa481d3a254172fd0ce0402362f
DIST rails-6.1.6.tgz 10993299 BLAKE2B 98a80cbefc1aafba68a22b60d3df6b81ab1e8247a75a07131aeed97ae621ea45b22918482537255547b68a5fc6b002f551b8b94492da3b1e6e24389a109e245c SHA512 04c578f6d8bdcd72691c8d4e51136424f2241a374cdfad1c3c2b436a4f5fde1955a600bcb98c6f416e22e1e561cd50f9ca5f5075deff94f258f8682dc9b00c1c
DIST rails-7.0.2.4.tgz 11014591 BLAKE2B 4a678dddca134769a40d73a6652a6aa273456288c19ddbe7611ae40a14860abf77226ab351ead92647fb471751521377c51cafae40383198ff3d3477bc257b55 SHA512 948cf58dd6ac517fb4b1e63c3a1dbfcf2405fd224ea150cb92f5805939d3a458ad26e139b1c6069cc587c01f15694be14e119ee56769a611e6b6eaa0eae5a68c
DIST rails-7.0.3.1.tgz 11049683 BLAKE2B 31aa9c20b4add7e11b832aff57fcf78284b7f28e71cfc71b5769c65170f1fff3f33d73224bbfa826852a59aac30671ff7c3ef19cbe0aaabc8528a805c6b98e8a SHA512 2ad615df9e019193489d5ce82152fd0ff12d8435401258b2b8a87d1c5da46587cdd45dc483847891f7b8be1d019b09b77a48fa7849d5260ee6fdbbf6df64ef03
diff --git a/dev-ruby/activesupport/activesupport-6.1.6.1.ebuild b/dev-ruby/activesupport/activesupport-6.1.6.1.ebuild
new file mode 100644
index 000000000000..cfe7a844bc9b
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-6.1.6.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/concurrent-ruby-1.0.2:1
+ >=dev-ruby/i18n-1.6:1
+ dev-ruby/tzinfo:2
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/zeitwerk-2.3:2
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ dev-ruby/connection_pool
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack
+ dev-ruby/rexml
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\)/ s:^:#:" \
+ -e '/group :\(doc\|rubocop\|job\|cable\|storage\|ujs\|test\) do/,/^end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"; gem "rack"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+# sed -i -e '1igem "tzinfo", "~> 1.1"' test/abstract_unit.rb || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+}